7.2 Тепплоперенос и Излучение

СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
Тьюториал STAR-CCM+ с составным телом:
Моделирование охлаждения видеокарты
(Multi-Part Solid Tutorial: Graphics Card Cooling)
В данном тьюториале демонстрируется, как можно моделировать несколько твердых
частей в отдельной среде (continuum) с использованием физической модели «Составное
тело» (Multi-Part Solid).
Используемая геометрия состоит из упрощенной видеокарты (graphics card),
размещенной внутри системного блока компьютера (PC tower case).
Номер Описание
(Index) (Description)
1
Системный блок
(PC Tower Case)
2
Вход 1
(Inlet 1)
3
Вход 2
(Inlet 2)
4
Видеокарта
(Graphics Card)
5
Выход 2
(Outlet 2)
6
Выход 1
(Outlet 1)
Материалы видеокарты и ее частей представлены на следующей схеме.
1
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
СИНЦ
Номер
(Index)
1
2
3
4
5
6
7
Описание
(Description)
Теплоотвод
(Heat Sink)
Конденсатор
(Capacitor)
Чип памяти
(Memory Chip)
Корпус чипа графического
процессора
(GPU Chip Casing)
Печатная плата
(Printed Circuit Board)
Блок разъема
(Connector Port Block)
Задняя панель
(Back Plate)
Версия 9.06
Дата: 12.12.2014
Материал
(Material)
Алюминий
(Aluminum)
Оксид алюминия
(Alumina)
Кремний
(Silicon)
Алюминий
(Aluminum)
Стеклотекстолит
(стекловолокно) + Медь
(FR-4 + Copper)
Алюминий
(Aluminum)
Алюминий
(Aluminum)
Перед созданием физических сред (physics continua) и областей с использованием
модели «Составного тела» (Multi-Part Solid model) импортируйте поверхностную сетку
геометрии как отдельные части в STAR-CCM+. Будет использоваться многогранная сетка
(polyhedral mesh) с призматическими слоями. Чтобы построить сетку для тонких частей
геометрии, будет использован «Встроенный генератор для тонких объектов» (embedded
thin mesher).
2
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
Содержание (Contents)
Предварительные условия (Prerequisites)
Импорт геометрии (Importing the Geometry)
«Привязывание» (прикрепление) частей к областям (Assigning Parts to Regions)
Задание типов границ (Setting the Boundary Types)
Задание физических моделей (Selecting Physics Models)
«Привязывание» (прикрепление) сред к областям (Assigning Continua to Regions)
«Привязывание» (прикрепление) материалов к частям составного тела (Assigning
Materials to the Multi-Part Solid Parts)
Задание моделей для сетки (Setting Up the Mesh Models)
Создание отчетов объема для тепловыделяющих частей (Creating Volume Reports for
the Heat-Generating Parts)
Задание объемных источников тепла (Setting Volumetric Heat Sources)
Задание опорных значений и начальных условий (Setting Up Reference Values and
Initial Conditions)
Изменение типа интерфейса (Modifying the Interface Type)
Подготовка сцен для визуализации (Preparing Scenes for Visualization)
Визуализация прикрепленных лбъемных источников (Visualizing Assigned Volumetric
Heat Sources)
Создание температурных отчетов, мониторов и графиков (Reporting Temperature with
a Monitor and a Plot)
Изменение настроек решателя и критериев остановки (Modifying Solver Settings and
Stopping Criteria)
Запуск расчёта (Running the Simulation)
Визуализация результатов (Visualizing the Results)
Заключение (Summary)
Предварительные условия (Prerequisites)
Руководство данного тьюториала с расчетом составного тела предполагает, что Вы
уже знакомы с некоторыми методами работы в STAR-CCM+.
Для выполнения
методиками:
тьюториала,
Вам
следует
Методики
(Techniques)
Рабочий процесс в STAR-CCM+
(The STAR-CCM+ workflow)
Использование инструментов визуализации, сцен и
графиков (Using visualization tools, scenes, and plots)
ознакомиться
со
Соответствующий тьюториал
(Associated Tutorial)
Введение в STAR-CCM+
(Introduction to STAR-CCM+)
Введение в STAR-CCM+
(Introduction to STAR-CCM+)
Импорт геометрии (Importing the Geometry)
3
следующими
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
Для построения сетки сначала необходимо импортировать геометрию CAD в
формате Parasolid.
Выполните следующие шаги:
1. Запустите STAR-CCM+.
2. Начните новую задачу.
3. Выберите папку «Файл > Импортировать > Импортировать поверхностную сетку»
(File > Import > Import Surface Mesh).
4. В диалоговом окне «Открыть» (Open) зайдите в установочную директорию
doc/startutorialsdata/heatTransferAndRadiation/data.
5. Выберите graphicsCardAndEnclosure.x_t, затем нажмите «Открыть» (Open).
6. Чтобы принять все настройки по умолчанию в окне «Опции импорта поверхности»
(Import Surface Options), нажмите ОК.
Обратите внимание: Если Вы желаете использовать «Модель составного тела»
(Multi-Part Solid model), импортируйте всю CAD геометрию как части.
Как результат, будут импортированы 22 части. Контакты частей (part contacts) между
совпадающими частями будут генерироваться автоматически во время процесса
импортирования.
7. Сохраните задачу под именем graphicsCardCooling.sim.
«Привязывание» (прикрепление) частей к областям
(Assigning Parts to Regions)
Для данного моделирования потребуются три области: одна для жидкости (fluid) и
две для твердых тел (solids).
Анизотропные материалы, например, для «Печатной платы» (Printed Circuit Board
(PCB)), требуют выделенных физических сред (physics continua) и областей. Поэтому для
данного тьюториала и нужны две твердотельные области (solid regions). Оставшиеся
твердотельные части будут содержаться в одной твердой области.
Чтобы создать области:
1. Нажмите правой кнопкой мыши на папку «Геометрия > Части > Воздух» (Geometry
> Parts > Air) и выберите «Назначить части областям» (Assign Parts to Regions).
2. В диалоговом окне «Назначить части областям» (Assign Parts to Regions) выберите
опцию «Создать границу для каждой поверхности части» (Create a Boundary for
Each Part Surface). Выбор этой опции позволяет STAR-CCM+ создавать одну
область для выбранной части и отдельные границы для каждой названной
поверхности.
3. Нажмите «Применить» (Apply). Будет создана новая область с именем по
умолчанию «Область» (Region).
Создадим область для всех твердотельных частей, кроме PCB:
4. Выберите все части в диалоговом окне.
4
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
5. Снимите выделения в полях для редактирования, соответствующих частям
«Воздух» (Air) и PCB.
6. Нажмите «Применить» (Apply). Будет создана область с именем «Область 2»
(Region 2).
Наконец, создадим последнюю область для PCB:
7. Отмените выбор всех частей в диалоговом окне.
8. Выберите часть PCB.
9. Нажмите «Применить» (Apply) и затем затем «Закрыть» (Close).
Будет создана последняя область Region 3.
10. Переименуем только что созданные области. Новые имена представлены в таблице
ниже.
Старое название
Область (Region)
Область 2 (Region 2)
Область 3 (Region 3)
Новое название
Воздух (Air)
Компоненты GPU (GPU Components)
PCB
На снимке с экрана ниже показаны новые области.
Задание типов границ (Setting the Boundary Types)
Определим типы границ для видеокарты.
Для определения типов входных и выходных границ:
1. Выберите папку «Области > Воздух > Границы» (Regions > Air > Boundaries) и
установите следующие свойства:
Папка (Node)
Свойство (Property)
5
Значения (Setting)
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Воздух.Вход 1 (Air.Inlet 1)
Тип (Type)
Воздух.Вход 2 (Air.Inlet 2)
Тип (Type)
Воздух.Выход 1 (Air.Outlet 1)
Тип (Type)
Воздух.Выход 2 (Air.Outlet 2)
Тип (Type)
Версия 9.06
Дата: 12.12.2014
Скорость на входе (Velocity
Inlet)
Скорость на входе (Velocity
Inlet)
Давление
на
выходе
(Pressure Outlet)
Давление
на
выходе
(Pressure Outlet)
Границы показаны на рисунке ниже.
Задание физических моделей (Selecting Physics Models)
Этот тьюториал потребует создания трех физических сред (physics continua), одной –
для воздуха, одной – для анизотропного материала (PCB) и одной – для оставшихся
твердых частей видеокарты.
6
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
Содержание (Contents)
Создание физической среды для компонентов графического процессора (Creating the
Physics Continuum for the GPU Components)
Определение свойств материала компонентов графического процессора (Defining
Material Properties of GPU Components)
Создание физической среды для области Воздух
(Creating the Physics Continuum for the Air Region)
Определение свойств материала воздуха (Defining Material Properties of Air)
Создание физической среды для области печатной платы (Creating the Physics
Continuum for the PCB Region)
Определение свойств материала печатной платы (Defining Material Properties of PCB)
Создание физической среды для компонентов графического
процессора (Creating the Physics Continuum for the GPU Components)
В данном тьюториале с охлаждением видеокарты начните настройку физических
моделей с установки физических континуумов (сред) для компонентов GPU.
Создадим первую физическую среду (physics continuum), которая будет
использоваться для моделирования всех твердотельных компонентов, смонтированных на
печатной плате (PCB):
1. Создайте физическую среду.
2. Переименуйте ее в «Компоненты GPU» (GPU Components).
3. Для физического континуума «Континуумы > Компоненты GPU» (Continua > GPU
Components) выберите следующие модели по порядку:
Группа моделей (Group Box)
Пространство (Space)
Модель (Model)
Трехмерная модель (Three-Dimensional)
Градиенты
(Gradients)
(выбрана
автоматически)
Стационарный (Steady)
Составное тело (Multi-Part Solid)
Разделенная
энергия
твердого
тела
(Segregated Solid Energy)
Постоянная плотность (Constant Density)
Время (Time)
Материал (Material)
Дополнительные модели (Optional Models)
Уравнение состояния (Equation of State)
4. Нажмите «Закрыть» (Close).
5. Для просмотра выбранных моделей откройте папку «Компоненты GPU > Модели»
(GPU Components > Modeks)
7
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
Определение свойств материала компонентов графического
процессора (Defining Material Properties of GPU Components)
В среде GPU Components моделируется несколько твердотельных частей. Некоторые
части выполнены из различных материалов.
Чтобы определить эти материалы в модели составного тела (multi-part solid):
1. Выберите папку «Континуумы > Компоненты GPU > Модели > Составное тело»
(Continua > GPU Components > Models > Multi-Part Solid).
2. Нажмите правой кнопкой мыши на папку «Твердые тела» (Solids) и выберите
«Выбрать компоненты смеси» (Select Mixture Components).
3. В диалоговом окне «Выбрать компоненты смеси» (Select Mixture Components)
откройте папку «База данных материалов > Стандартные > Твердые (Сплошные)»
(Material Databases > Standard > Solids).
4. Выберите три материала из списка. Материалы, выбираемые здесь неважны,
поскольку свойства материалов будут изменены на последующих этапах.
8
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
5. Нажмите «Применить» (Apply), а затем «Закрыть» (Close).
6. Переименуйте материалы в «Алюминий» (Aluminum), «Оксид алюминия»
(Alumina) и «Кремний» (Silicon).
7. Откройте папку «Составное тело» (Multi-Part Solid) и установите следующие
свойства материала:
Папка (Node)
Aluminum
(алюминий)
Свойства материала
(Material Properties)
Плотность
(kg/m^3)
Константа (Constant)
Свойство (Property)
Значения (Setting)
Значение (Value)
2700
9
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Удельная теплоемкость
(J/kg-k)
Константа (Constant)
Теплопроводность (Thermal
Conductivity) (W/m-K)
Константа (Constant)
Версия 9.06
Дата: 12.12.2014
Значение (Value)
896
Значение (Value)
167
Папка (Node)
Alumina
(оксид алюминия)
Свойства материала
(Material Properties)
Плотность
(kg/m^3)
Константа (Constant)
Удельная теплоемкость
(J/kg-k)
Константа (Constant)
Теплопроводность (Thermal
Conductivity) (W/m-K)
Константа (Constant)
Свойство (Property)
Значения (Setting)
Значение (Value)
3960
Значение (Value)
850
Значение (Value)
30
Папка (Node)
Silicon
(кремний)
Свойства материала
(Material Properties)
Плотность
(kg/m^3)
Константа (Constant)
Свойство (Property)
Значения (Setting)
Значение (Value)
2330
Значение (Value)
700
Значение (Value)
124
Удельная теплоемкость
(J/kg-k)
Константа (Constant)
Теплопроводность (Thermal
Conductivity) (W/m-K)
Константа (Constant)
8. Нажмите «Закрыть» (Close).
Создание физической среды для области Воздух
(Creating the Physics Continuum for the Air Region)
Создадим физическую среду (physics continuum), которая будет использоваться для
моделирования воздуха в жидкообразной области (fluid domain).
10
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
Будет использоваться постоянная плотность с моделью Boussinesq. Сетка будет
содержать четыре призматических слоя; в дополнении к сетке используется «Реализуемая
двухслойная K-Epsilon» (Realizable K-Epsilon Two-Layer) турбулентная модель.
1. Создайте физическую среду.
2. Переименуйте ее в «Воздух» (Air).
3. Для физической среды «Континуумы > Воздух» (Continua > Air) выберите
следующие модели по порядку:
Группа моделей (Group Box)
Пространство (Space)
Модель (Model)
Трехмерная модель (Three-Dimensional)
Градиенты
(Gradients)
(выбрана
автоматически)
Время (Time)
Стационарный (Steady)
Материал (Material)
Газ (Gas)
Поток (Flow)
Разделенное течение (Segregated Flow)
Уравнение состояния (Equation of State)
Постоянная плотность (Constant Density)
Вязкостный режим (Viscous Regime)
Турбулентный (Turbulent)
Осредненные по Рейнольдсу уравнения
Навье-Стокса (Reynolds-Averaged NavierStokes) (выбрана автоматически)
Осредненная
по
Рейнольдсу Модель турбулентности K-Epsilon (Kтурбулентность
(Reynolds-Averaged Epsilon Turbulence)
Turbulence)
Реализуемая двухслойная модель K-Epsilon
(Realizable K-Epsilon Two-Layer) (выбрана
автоматически)
Двухслойная пристеночная модель для
любых y+ (Two-Layer All y+ Wall
Treatment) (выбрана автоматически)
Дополнительные модели (Optional Models)
Сила тяжести» (Gravity)
Разделенная
температура
жидкости
(Разделенная
энергия
жидкости
для
температуры) (Segregated Fluid Temperature)
Модель Буссинеска (Boussinesq Model)
4. Нажмите «Закрыть» (Close).
5. Для просмотра выбранных моделей откройте «Воздух > Модели» (Air > Models).
11
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
Определение свойств материала воздуха
(Defining Material Properties of Air)
Модель Буссинеска (Boussinesq Model) требует от Вас задания коэффициента
теплового расширения (thermal coefficient of expansion) жидкообразной области.
Чтобы определить это свойство:
1. Выберите папку «Континуумы > Воздух > Модели > Газ > Воздух > Свойства
материала > Коэффициент теплового расширения» (Continua > Air > Models > Gas >
Air > Material Properties > Thermal Expansion Coefficient).
2. Выберите папку «Константа» (Constant) и установите «Значение» (Value) на 3.33E3 /K. >
Создание физической среды для области печатной платы
(Creating the Physics Continuum for the PCB Region)
Данная среда предполагает работу с различной теплопроводностью.
Печатная плата (PCB) построена из слоев стеклотекстолита (FR-4 glass-reinforced
laminate, стекловолокна) и медной фольги (copper foil). Как результат, печатная плата
(PCB) имеет разную теплопроводность (thermal conductivity) в пределах одного и того же
слоя и разную теплопроводность между различными слоями.
12
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
1. Создайте другую физическую среду (physics continuum).
2. Переименуйте ее в PCB.
3. Для физического континуума «Континуумы > PCB» (Continua > PCB) выберите
следующие модели по порядку:
Группа моделей (Group Box)
Пространство (Space)
Время (Time)
Материал (Material)
Дополнительные модели (Optional Models)
Уравнение состояния (Equation of State)
Модель (Model)
Трехмерная модель (Three-Dimensional)
Градиенты
(Gradients)
(выбрана
автоматически)
Стационарный (Steady)
Сплошной (Solid)
Разделенная
энергия
твердого
тела
(Segregated Solid Energy)
Постоянная плотность (Constant Density)
4. Нажмите «Закрыть» (Close).
5. Для просмотра выбранных моделей откройте папку «PCB > Модели» (PCB >
Models).
Определение свойств материала печатной платы
(Defining Material Properties of PCB)
Переименуем папку твердого тела и зададим его свойства.
Отредактируйте свойства печатной платы (PCB):
1. Переименуйте материал папки «Континуумы > PCB > Модели > Твердый»
(Continua > PCB > Models > Solid) в «FR-4 + Copper» (Стеклотекстолит
(стекловолокно) + Медь).
2. Выберите папку «FR-4 + Copper > Свойства материала» (FR-4 + Copper > Material
Properties) и установите следующие свойства материала:
13
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Папка (Node)
Плотность
(kg/m^3)
Константа (Constant)
Удельная теплоемкость
(J/kg-k)
Константа (Constant)
Теплопроводность (Thermal
Conductivity) (W/m-K)
Версия 9.06
Дата: 12.12.2014
Свойство (Property)
Значения (Setting)
Значение (Value)
33
Значение (Value)
Метод (Method)
37
Анизотропный (Anisotropic).
Анизотропные свойства печатной платы (PCB) будут определены позднее.
«Привязывание» (прикрепление) сред к областям
(Assigning Continua to Regions)
Поскольку в задаче присутствует несколько областей и физических сред, прикрепим
физические среды (physics continua) к соответствующим областям:
1. Прикрепите физические континуумы к соответствующим областям:
Область
Воздух (Air)
Компоненты GPU (GPU Component)
PCB
Физический континуум
Воздух (Air)
Компоненты GPU (GPU Component)
PCB
«Привязывание» (прикрепление) материалов к частям составного
тела (Assigning Materials to the Multi-Part Solid Parts)
Область GPU Components содержит несколько твердотельных частей. Вам
потребуется «связать» эти части с правильным материалом.
Материалы были определены в физической среде «Составного тела» (Multi-Part
Solid). Прикрепим части к материалам следующим образом:
1. Откройте папку «Области > Компоненты GPU > Физические значения > Группы
материала части» (Regions > GPU Components > Physics Values > Material Part
Groups).
2. Нажмите на кнопку пользовательского редактора
рядом со свойством «Части»
(Parts) для папки «Алюминий» (Aluminum).
3. В диалоговом окне «Алюминий» (Aluminum) выберите части, выполненные из
алюминия (Aluminum).
14
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
• Чип графического процессора (GPU Chip)
• Блок теплоотвода (Heatsink Block)
• Панель (Plate)
• Port Block 1
• Port Block 2
• Port Block 3
Рисунок ниже иллюстрирует диалоговое окно по окончании операции.
4. Нажмите OK.
5. Прикрепите другие части к оставшимся материалам.
• Все конденсаторы, с Capacitor 1 по Capacitor 6, к папке «Оксид алюминия»
(Alumina).
• Все чипы памяти, с Memory Chip 1 по Memory Chip 8, к папке «Кремний» (Silicon).
Части могут быть прикреплены только к одному конкретному материалу. Части,
которые уже прикреплены к материалу, убираются из того списка материала частей, когда
Вы прикрепляете их к новому материалу.
6. Сохраните задачу.
15
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
Задание моделей для сетки (Setting Up the Mesh Models)
Теперь мы можем построить объемную сетку с использованием генератора
многогранной сетки (polyhedral mesher).
Поскольку видеокарта состоит из тонких частей, то также будет использован
встроенный генератор для тонких объектов (embedded thin mesher).
1. Создайте сеточную среду.
2. Для сеточной среды «Среды > Сетка 1» (Continua > Mesh 1) выберите следующие
модели по порядки:
Группа модели (Group Box)
Поверхностная сетка (Surface Mesh)
Объемная сетка (Volume Mesh)
Дополнительные модели (Optional Models)
Модель (Model)
Генератор поверхностной сетки (Surface
Remesher)
Генератор многогранной сетки (Polyhedral
Mesher)
Встроенный генератор сетки для тонких
объектов (Embedded Thin Mesher)
3. Нажмите «Закрыть» (Close).
4. Для просмотра выбранных моделей откройте папку «Сетка 1 > Модели» (Mesh 1 >
Models).
Изменим параметры модели для сетки:
5. Выберите папку «Сетка 1 > Модели > Встроенный генератор сетки для тонких
объектов» (Mesh 1 > Models > Embedded Thin Mesher) и отметьте галочкой поле для
редактирования свойства «Задать предел толщины» (Customize Thickness
Threshold).
Активация этого свойства позволяет Вам задавать указанное пользователем
предельное значение (custom threshold value) для встроенного генератора для
16
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
тонких объектов (embedded thin mesher). Сетка любой части, которая тоньше этого
предела (threshold), будет строиться с использованием встроенного генератора
сетки для тонких объектов (embedded thin mesher).
Отредактируем опорные величины сетки:
6. Выберите папку «Сетка 1 > Опорные величины > Базовый размер» (Mesh 1 >
Reference Values > Base Size) и установите его «Значение» (Value) на 0.02 m.
7. Выберите папку «Размер на поверхности > Относительный минимальный размер»
(Surface Size > Relative Minimum Size) и установите «Процент от базового размера»
(Percentage of Base) на 10.
8. Выберите папку «Толщина тонкого объекта» (Thin Solid Thickness) и установите
тип «Размера» (Size) на вариант «Абсолютный» (Absolute).
9. Выберите папку «Толщина тонкого объекта > Абсолютный размер» (Thin Solid
Thickness > Absolute Size) и установите его «Значение» (Value) на 4 mm.
10. Сохраните задачу.
Содержание (Contents)
Создание форм объема и определение контролей объема (Creating the Volume Shapes and
Defining the Volumetric Controls)
Построение Объемной Сетки (Generating the Volume Mesh)
Создание форм объема и определение контролей объема
(Creating the Volume Shapes and Defining the Volumetric Controls)
Будем использовать форму объема (volume shape) для управления измельчением
сетки вокруг видеокарты.
Чтобы создать форму объема (volume shape):
1. Щелкните правой кнопкой мыши по папке «Инструменты > Формы объема» (Tools
> Volume Shapes) и выберите «Новая форма > Блок» (New Shape > Block).
2. В появившемся встроенном диалоговом окне «Создать блочную форму объема»
(Create Block Volume Shape) задайте следующие установки в поле «Максимальные
и Минимальные координаты» (Maximum and Minimum Coordinates).
Свойство (Property)
Угол 1 (Corner 1)
Угол 2 (Corner 2)
Значение (Setting)
[-0.4 m, -0.15 m, -0.06 m]
[-0.07 m, -0.1 m, 0.07 m]
Предварительный просмотр (preview) блочной формы представлен в сцене ниже.
17
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
3. Выберите «Создать» (Create), а затем «Закрыть» (Close).
Новая форма Block 1 будет добавлена в папку «Инструменты > Формы объема»
(Tools > Volume Shapes).
Продолжим, создавая контрольные объемы (volumetric control):
4. Нажмите правой кнопкой мыши на «Континуумы > Сетка 1 > Контрольные
объемы» (Continua > Mesh 1 > Volumetric Controls), а затем выберите «Новый»
(New).
Новый папка «Контрольный объем 1» (Volumetric Control 1) будет добавлена в папку
«Контрольные объемы» (Volumetric Controls).
5. Выберите только что созданную папку «Контрольный объем 1» (Volumetric Control
1).
6. Нажмите на кнопку пользовательского редактора
рядом со свойством «Формы»
(Shapes).
7. В появившемся диалоговом окне «Контрольный объем 1» (Volumetric Control 1)
выберите Block 1.
8. Нажмите OK.
9. Раскройте папку «Контрольный объем 1 > Условия для сетки > Генератор
многогранной сетки» (Volumetric Control 1 > Mesh Conditions > Polyhedral Mesher),
и отметьте галочкой поле для редактирования свойства «Задать параметры
генератора многогранных ячеек» (Customize polyhedral mesher).
10. Раскройте папку «Контрольный объем 1 > Условия для сетки > Генератор
поверхностной сетки» (Volumetric Control 1 > Mesh Conditions > Surface Remesher),
18
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
и отметьте галочкой поле для редактирования свойства «Задать параметры
генератора поверхностной сетки» (Customize surface remesher).
11. Выберите папку «Сеточные значения > Задаваемая величина > Относительный
размер» (Mesh Values > Custom Size > Relative Size) и установите «Процент от
базового размера» (Percentage of Base) на 25.
12. Сохраните задачу.
Построение Объемной Сетки (Generating the Volume Mesh)
Создадим и визуализируем согласованную сетку.
Постройте объемную сетку.
1. Нажмите на кнопку «Генерировать объемную сетку» (Generate Volume Mesh)
в
панели инструментов (Mesh toolbar).
Конформная (согласованная, conformal) сетка будет создана между всеми областями.
2. Чтобы визуализировать сетку, создайте сцену для отображения сетки (mesh scene) и
взгляните на сетку жидкообразной области
3. Выбеирте «Сцена для отображения сетки 1 > Окна отображения > Сетка 1 > Части»
(Mesh Scene 1 > Displayers > Mesh 1 > Parts).
4. Снимите выделение с поля «Области > Воздух» (Regions > Air).
19
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
Сетка для видеокарты показана на скриншоте ниже.
5. Сохраните задачу.
Создание отчетов объема для тепловыделяющих частей
(Creating Volume Reports for the Heat-Generating Parts)
Для вычисления объема каждой тепловыделяющей части (heat-generating part) будут
созданы отчеты.
Потребуется один отчет на тип части (part type).
Чтобы создать объемный отчет (volume report):
1. Щелкните правой кнопкой мыши по папке «Отчеты» (Reports) и выберите «Новый
отчет > Сумма» (New Report > Sum).
2. Переименуйте отчет в GPU Volume.
3. Выберите папку «Отчеты > GPU Volume» (Reports > GPU Volume) и установите его
«Скалярную переменную» (Scalar Field Function) на вариант «Объем» (Volume).
4. Отредактируйте свойство «Части» (Parts) папки GPU Volume.
5. В диалоговом окне GPU Volume выберите «Части > GPU Chip» (Parts > GPU Chip).
Внимание: оставьте папку «GPU Chip > Поверхности > Грани» (GPU > Surfaces > Faces)
не выбранной.
6. Нажмите OK.
7. Запустите отчет.
20
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
Объем GPU Chip равен 3.2e-06 m^3.
Создадим другой отчет для одного из чипов памяти (memory chips).
8. Скопируйте и вставьте отчет GPU Volume.
9. Переименуйте копию в Memory Volume.
10. Выберите свойство «Части» (Parts) папки «Объем памяти» (Memory Volume).
11. В диалоговом окне «Объем памяти» (Memory Volume):
a) Отмените выбор папки «Части > GPU Chip» (Parts > GPU Chip).
b) Выберите папку Memory Chip 1.
12. Нажмите OK.
Оставшиеся чипы памяти имеют тот же самый объем, таким образом, тот же самый
объемный отчет будет использоваться для каждого чипа памяти.
Задание объемных источников тепла
(Setting Volumetric Heat Sources)
Тепло, выделяемое электронными компонентами, моделируется в STAR-CCM+ с
использованием объемных источников тепла (volumetric heat sources). Источники тепла
задаются для областей.
Вы можете получить объемное выделение тепла (volumetric heat generation) для
компонента, исходя из соотношения общей тепловой мощности (total heat output) к его
объему. Будем использовать объемные репорты, созданные ранее, в функциях поля,
которые вычисляют соотношение.
Объемные отчеты, созданные в предыдущем разделе, используются в переменной
для вычисления объемного источника тепла (volumetric heat source) тепловыделяющих
частей на основе представленных источников тепла. Чип графического процессора (GPU
chip) излучает 25 W тепла. Каждый чип памяти (memory chip) излучает 4 W тепла. Части
идентифицируются с использованием их свойства «Индекс части» (Part Index).
Соответствующий объемный отчет выбирается с использованием названия переменной.
1. Чтобы проверить номер «Индекса части» (Part Index), выберите ее папку и
проверьте свойство «Индекс» (Index) для нее. Например, в скриншоте ниже индекс
части для папки «Геометрия > Части > GPU Chip» (Geometry > Parts > GPU Chip)
равен 13.
21
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
Номер «Индекса части» (Part Index) для чипов памяти показан в следующей таблице:
Название Части Индекс Части
(Part Name)
(Part Index)
Чип памяти 1
12
(Memory Chip 1)
Чип памяти 2
14
(Memory Chip 2)
Чип памяти 3
15
(Memory Chip 3)
Чип памяти 4
16
(Memory Chip 4)
Чип памяти 5
17
(Memory Chip 5)
Чип памяти 6
18
(Memory Chip 6)
Чип памяти 7
19
(Memory Chip 7)
Чип памяти 8
20
(Memory Chip 8)
Чтобы создать пользовательскую переменную:
2. Щелкните правой кнопкой мыши по папке «Инструменты > Переменная» (Tools >
Field Functions) и выберите «Новый > Скаляр» (New > Scalar).
22
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
3. Переименуйте эту переменную в «Объемный источник тепла» (Volumetric Heat
Source).
4. Выберите папку «Объемный источник тепла» (Volumetric Heat Source) и задайте
следующие свойства:
Свойство (Property)
Имя переменной (Function Name)
Размерности (Dimensions)
Определение (Definition)
Значение (Setting)
VolumetricHeatSource
Мощности/Объем (Power/Volume).
($CellGeometryPartIndex ==
13) ?
(25/$GPUVolumeReport) :
(($CellGeometryPartIndex
== 12) ||
($CellGeometryPartIndex ==
14) ||
($CellGeometryPartIndex ==
15) ||
($CellGeometryPartIndex ==
16) ||
($CellGeometryPartIndex ==
17) ||
($CellGeometryPartIndex ==
18) ||
($CellGeometryPartIndex ==
19) ||
($CellGeometryPartIndex ==
20) ?
(4/$MemoryVolumeReport) :
0)
Единицы переменной определяются как W/m^3.
5. Сохраните задачу.
Содержание (Contents)
Установка физических значений и условий (Setting Up Physics Values and Conditions)
Установка физических значений и условий
(Setting Up Physics Values and Conditions)
Данный раздел тьюториала посвящен установке физических значений и условий для
областей.
Определим анизотропную теплопроводность области PCB:
1. Выберите папку «Области > PCB > Физические значения > Анизотропная
теплопроводность» (Regions > PCB > Physics Values > Anisotropic Thermal
Conductivity).
23
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
2. Откройте папку «Тензор главных напряжений»
следующие свойства:
Папка (Node)
Свойство (Property)
Компонента XX (XX Component)
Константа (Constant)
Значение (Value)
Компонента YY (YY Component)
Константа (Constant)
Значение (Value)
Компонента ZZ (ZZ Component)
Константа (Constant)
Значение (Value)
Версия 9.06
Дата: 12.12.2014
(Principal Tensor) и задайте
Значение (Setting)
10 W/m-k
0.5 W/m-k
10 W/m-k
В области GPU Component зададим использование пользовательской переменной,
созданной нами в предыдущем разделе, в качестве источника энергии:
3. Выберите папку «Области > GPU Components > Физические условия > Опция
источника энергии» (Regions > GPU Components > Physics Conditions > Energy
Source Option) и установите «Опцию источника энергии» на вариант «Объемный
источник тепла» (Volumetric Heat Source).
4. Выберите папку «Физические значения > Объемный источник тепла» (Physics
Values > Volumetric Heat Source) и установите его «Метод» (Method) на вариант
«Переменная» (Field Function).
5. Выберите папку «Объемный источник тепла > Переменная» (Volumetric Heat
Source > Field Function) и установите его «Скалярную переменную» (Scalar
Function) на «Объемный источник тепла» (Volumetric Heat Source).
Установка опорных величин и начальных условий
(Setting Up Reference Values and Initial Conditions)
Нам необходимо задать силу тяжести и скорость.
Определим опорную силу тяжести (reference gravity) и начальную скорость
следующим образом:
1. Выберите папку «Континуумы> Воздух > Опорные величины > Сила тяжести»
(Continua > Air > Reference Values > Gravity) и установите ее «Значение» (Value) на
[0.0, -9.81, 0.0] m/s^2.
2. Выберите папку «Воздух > Начальные условия > Скорость > Константа» (Air >
Initial Conditions > Velocity > Constant) и установите ее «Значение» (Value) на [-1,
0.0, 0.0] m/s.
Изменение типа интерфейса (Modifying the Interface Type)
Чтобы получать правильную теплопроводность на каждой стороне интерфейса,
требуются контактные интерфейсы (contact interfaces).
Убедимся, что все интерфейсы в геометрии являются контактными (Contact
Interfaces):
1. Раскройте папку «Интерфейсы» (Interfaces).
2. Выберите все интерфейсы и задайте «Тип» (Type) на вариант «Контактный
интерфейс» (Contact Interface).
24
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
Подготовка сцен для визуализации
(Preparing Scenes for Visualization)
Создадим две скалярные сцены: одну для отображения величины скорости в
плоскости, проходящей через корпус системного блока, а другую для отображения
температуры видеокарты.
Начнем с создания плоскости сечения (section plane):
1. В графическом окне выберите вкладку «Геометрическая сцена 1» (Geometry Scene
1).
2. Щелкните правой кнопкой мыши по папке «Производные части» (Derived Parts) и
выберите «Новая часть > Сечение > Плоскость» (New Part > Section > Plane).
3. Во встроенной панельке «Создать сечение» (Create Section) установите следующие
значения:
a) Чтобы выбрать вводимые части, нажмите «Выбрать» (Select)
b) В диалоговом окне «Выбрать объекты» (Select Objects) откройте папку
«Области» (Regions) и выберите все три ее области.
c) Установите начало координат (origin) на [0 m, 0 m, 0.035 m].
d) Установите координаты нормали (normal) на [0 m, 0m, 1 m].
e) В группе «Показать» (Display) выберите «Нет окна отображения» (No
Displayer).
Рисунок ниже показывает диалоговое окно по завершении.
25
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
4. Нажмите «Создать» (Create), а затем «Закрыть» (Close).
Зададим скалярную сцену.
5. Создайте скалярную сцену.
6. Откройте «Окна отображения > Скаляр 1 > Части» (Displayers > Scalar 1 > Parts).
7. В диалоговом окне «Редактировать» (Edit) выберите папку «Производные части >
сечение плоскостью» (Derived Parts > plane section).
8. В дереве объектов выберите «Скаляр 1 > Скалярная переменная» (Scalar 1 > Scalar
Field).
26
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
9. Установите «Переменную» (Function) на вариант «Скорость > Величина» (Velocity
> Magnitude).
10. Выберите папку «Скаляр 1» (Scalar 1) и установите его «Тип контура» (Contour
Style) на вариант «Сглаженный» (Smooth Filled).
Вторая скалярная сцена будет отображать температуру видеокарты.
11. Создайте скалярную сцену.
12. Выберите «Окна отображения > Скаляр 1 > Части» (Displayers > Scalar 1 > Parts).
13. В диалоговом окне «Редактировать» (Edit) откройте папку «Области» (Regions) и
выберите папки GPU Components и PCB.
14. Выберите папку «Скаляр 1 > Скалярная переменная» (Scalar 1 > Scalar Field):
15. Установите «Переменную» (Function) на вариант «Температура» (Temperature).
16. Установите «Единицы измерения» (Units) на C.
Визуализация прикрепленных объемных источников тепла
(Visualizing Assigned Volumetric Heat Sources)
Выполним визуализацию объемного источника тепла.
Объемный источник тепла для каждой тепловыделяющей части может быть
отображен на скалярной сцене. Эта информация содержится в пределах переменной
объемного источника тепла (volumetric heat source), созданной Вами ранее. Эта
переменная будет отображаться в скалярной сцене напрямую, однако будет показываться
среднее значение (average value) с обеих сторон граничных интерфейсов. Чтобы
отобразить значение ячейки (cell value), создадим пороговую (предельную) производную
часть (threshold derived part):
Создадим скалярную сцену пороговой производной частью.
1. Создайте скалярную сцену.
2. Создайте пороговую производную часть.
3. В появившейся встроенной панельке «Создать предел» (Create Threshold)
выполните следующее:
a) Чтобы выбрать вводимые части, нажмите «Выбрать» (Select).
b) В диалоговом окне «Выбрать объекты» (Select Objects) отмените выюор всех
объектов.
c) Откройте папку «Части» (Parts) и выберите все части, кроме Air и Heatsink
Block.Выберите только части, не поверхности.
Диалоговое окно по завершении показано на рисунке ниже.
27
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
d) Во встроенной панельке «Создать предел» (Create Threshold) установите
«Скаляр» (Scalar) на «Объемный источник тепла» (Volumetric Heat Source).
e) Нажмите на кнопку «Запрос» (Query) в группе «Диапазон скаляра» (Scalar Range).
Тем самым диапазон Минимум и Максимум (Min and Max range) будет заполнен
минимальными и максимальными значениями выбранной переменной.
f) Выберите «Существующее окно отображения» (Existing Displayer) и «Скаляр 1»
(Scalar 1) в группе «Показать» (Display).
Диалоговое окно по завершении показано на рисунке ниже.
28
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
4. Нажмите «Создать» (Create), а затем «Закрыть» (Close).
Примените переменную «объемный источник тепла» (volumetric heat source) к
скалярной сцене.
5. Выберите папку «Окна отображения > Скаляр 1 > Скалярная переменная»
(Displayers > Scalar 1 > Scalar Field) и установите его переменную (Function) на
«Объемный источник тепла» (Volumetric Heat Source).
6. Щелкните правой кнопкой мыши по папке «Окна отображения > Контур 1»
(Displayers > Outline 1) и выберите «Переключатель видимости» (Toggle Visibility).
7. Нажмите клавишу <S> на клавиатуре, чтобы изменить положение геометрии в
сцене.
Объемные источники тепла показаны на рисунке ниже.
29
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
8. Сохраните задачу.
Подготовка температурного отчета, монитора и графика
(Preparing the Temperature Report, Monitor and Plot)
Создадим монитор и график максимальной температуры, чтобы помочь Вам оценить
скорость, с которой решение сходится.
Отрисуем максимальную температуру. Этот график будет полезен для оценки
сходимости решения.
Чтобы отслеживать температуру:
1. Создайте отчет «Максимум» (Maximum).
2. Переименуйте новый отчет в «Максимальная температура» (Maximum
Temperature).
3. Выберите папку «Отчеты > Максимальная температура» (Reports > Maximum
Temperature) и установите «Скалярную переменную» (Scalar Field Function) на
вариант «Температура» (Temperature).
4. Задайте «Части» (Parts) как [Air, GPU Components, PCB].
5. Установите «Единицы измерения» (Units) на C.
6. Щелкните правой кнопкой мыши по папке «Максимальная температура»
(Maximum Temperature) и выберите «Создать монитор и график из отчета» (Create
Monitor and Plot from Report).
30
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
Новые под-папки монитора и графика будут добавлены к папкам «Мониторы»
(Monitors) и «Графики» (Plots), соответственно.
Изменение настроек решателя и критериев остановки
(Modifying Solver Settings and Stopping Criteria)
Изменим коэффициенты нижней релаксации (under-relaxation factors)
разделенных решателей ( Segregated solvers), чтобы помочь ускорить сходимость.
для
Выполните следующие шаги:
1. Откройте папку «Решатели» (Solvers) и задайте следующие свойства:
Папка (Node)
Свойство (Property)
Разделенное течение (Segregated Flow)
Коэффициент нижней
Скорость (Velocity)
релаксации (UnderRelaxation Factor)
Коэффициент
нижней
Давление (Pressure)
релаксации
(UnderRelaxation Factor)
Коэффициент нижней
Разделенная энергия
релаксации для твердых тел
(Segregated Energy)
(Solid Under-Relaxation
Factor)
Значение (Setting)
0.85
0.25
0.9999
Изменим наибольшее число итераций решателя. 300 итераций будет достаточно,
чтобы решение сошлось.
2. Выберите папку «Критерии остановки > Максимальное число шагов» (Stopping
Criteria > Maximum Steps) и установите «Максимальное число шагов» (Maximum
Steps) на 300.
3. Сохраните задачу.
Запуск задачи на расчет (Running the Simulation)
Теперь моделирование готово быть запущено на расчет.
Выполните следующие шаги:
1. Запустите расчет.
2. Для просмотра обновленных данных по мере выполнения расчёта используйте
скалярное окно отображения.
3. После завершения расчета, сохраните задачу.
Визуализация результатов (Visualizing the Results)
Теперь проверим результаты расчета.
31
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
1. После завершения расчета посмотрите в окна отображения скаляров и графиков.
На рисунке ниже показано течение воздуха (air flow) внутри корпуса компьютера.
32
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Температура видеокарты показана на рисунке ниже.
33
Версия 9.06
Дата: 12.12.2014
СИНЦ
Перевод документации STAR-CCM+
Тьюториал: Теплоперенос – Охлаждение видеокарты
Версия 9.06
Дата: 12.12.2014
График монитора температуры (temperature monitor plot) показан на рисунке ниже.
Решение сошлось.
Заключение (Summary)
Данный тьюториал по расчету составного тела, использующий упрощенную
геометрию системного компьютерного блока, продемонстрировал следующие
возможности STAR-CCM+:
• Импортирование CAD геометрии как «Части» (Parts)
• Использование модели материала «Составное тело» (Multi-Part Solid) для
моделирования нескольких твердых тел с разными материалами.
• Создание задаваемых пользователем переменных для вычисления «Объемного
источника тепла» (Volumetric Heat Source) от нескольких тепловыделяющих частей в
одной области.
34