Функция ЕСЛИ

Функция ЕСЛИ
Функция ЕСЛИ проверяет указанное условие на истинность.
Функция ЕСЛИ возвращает одно значение, если указанное условие дает в
результате значение ИСТИНА, и другое значение, если условие дает в результате
значение ЛОЖЬ. Например, формула
=ЕСЛИ(A1>10,"Больше 10","10 или меньше")
возвращает строку "Больше 10", если значение в ячейке A1 больше 10, и "10 или
меньше", если оно меньше или равно 10.
Задания с использование функции «ЕСЛИ»
Задание 1
В ячейке А1 задано произвольное число. В ячейке В1 вывести модуль этого числа.
Решение:
В ячейку В1 запишем формулу:
=ЕСЛИ(А1<0; -А1; А1)
То есть, если значение логического выражения А1<0 истинно (это означает, что
туда занесли отрицательное число), то в ячейке В1 оно будет с противоположном
знаком – положительным; если же значения указанного логического выражения ложно
(это означает, что в ячейке А1 число неотрицательное), то в ячейке В1 отобразится это
же число.
Логические связки «И», «ИЛИ».
В случае необходимости одновременной проверки нескольких условий можно
воспользоваться этими логическими связками.
Синтаксис:
И(усл1;усл2;усл3;…),
ИЛИ(усл1;усл2;усл3;…).
Чтобы результат проверки условия с логической связкой «И» был истинным,
необходимо, чтобы каждое из составляющих условие выражений было истинным.
Чтобы результат проверки условия с логической связкой «ИЛИ» был истинным,
необходимо, чтобы, по крайней мере, одно из составляющих условий было
истинным.
Задание 2
В ячейках А2 и В2 заданы произвольные числа. В ячейке С2 надо получить
следующий результат: если они оба положительны, то их надо вычесть; если оба
отрицательны – сложить; в любом другом случае их надо перемножить.
Решение:
Занесём в ячейку С2 следующую формулу:
=ЕСЛИ(И(А2<0;В2<0);А2+В2; ЕСЛИ(И(А2>0;В2>0);А2-В2;А2*В2))
Задание 3
Даны три числа, являющиеся коэффициентами квадратного уравнения. Необходимо в
отдельной ячейке вычислить дискриминант. В двух других ячейках, применив
функцию «ЕСЛИ» надо получить корни квадратного уравнения в случае
неотрицательного дискриминанта и вывести сообщение о том, что данное квадратное
уравнение не имеет решения в противном случае.
Задание 4
В трёх ячейках даны три числа, являющиеся углами треугольника. В четвёртой ячейке
вычислить сумму данных чисел. В пятой ячейке вывести тип этого треугольника:
тупоугольный, остроугольный, прямоугольный.
Проверить следующие условия:
1. все три числа должны быть положительными;
2. сумма углов треугольника должна составлять 180◦.
Задание 5
В трёх ячейках даны три числа, являющиеся сторонами треугольника. В четвёртой
ячейке вычислить его полупериметр. В пятой ячейке вычислить площадь такого
треугольника.
Проверить следующие условия:
1. все три числа должны быть положительными;
2. должны выполняться неравенства треугольника (сумма длин двух сторон строго
больше длины третьей стороны).
Формула Герона для вычисления площади треугольника:
abc
p
– полупериметр, S  p p  a  p  b  p  c  .
2
В Excel для вычисления квадратного корня применяется функция «КОРЕНЬ».
Первые 5 заданий выполнить на одном листе одной книги.
Задание 6
Задание выполнить на втором листе книги.
Создайте электронную таблицу учёта платы за квартиру согласно образцу.
Тариф за 1 кв. м:
Срок оплаты:
Пени за 1 день:
№
Фамилия
квартиры квартирос.
Квартплата
5 р.
10 мар
Площадь
кв. м
Сумма
Дата
Просрочка Штраф
оплаты
Итого
1. Все заголовки столбцов должны быть выровнены по центру как по горизонтали,
так и по вертикали, при определении формата ячейки примените опцию переноса
слов.
2. Столбец «№ квартиры»: 10, 11, 12, …, 50. Центральное выравнивание.
3. Столбец «Фамилия квартиросъемщика»: Иванов, Петров, Сидоров, Краснов,
Белов, все остальные Куропаткин 1, Куропаткин 2, …
4. Столбец «Площадь»: 70; 69,5; 69 и т.д. (каждая следующая на 0,5 кв. м меньше
предыдущей), выравнивание центральное.
5. Столбец «Сумма»: для каждой квартиры умножается значение из графы
«Площадь» на значение из графы «Тариф» (которое может быть изменено
учителем во время работы); формат рублёвый без копеек.
6. Столбец «Дата оплаты»: с 10 февраля, каждая следующая квартира произвела
оплату на день позже предыдущей. Формат «Дата», полная форма.
7. Столбец «Просрочка»: если оплата была произведена до срока оплаты
включительно, то автоматически ставится 0 (ноль); если позже срока, то должно
подсчитываться количество дней просрочки («Дата оплаты» - «Срок оплаты»).
Срок оплаты может меняться учителем во время работы с вашей таблицей. Данные
выравнивайте по центру.
8. Столбец «Штраф»: для каждой квартиры умножается значение из графы «Пени за
1 день» на значение из графы «Просрочка». Формат денежный без копеек.
9. Столбец «Итого»: суммируются значения из граф «Сумма» и «Штраф», формат
денежный без копеек.
10. В конце ведомости должна автоматически подсчитываться следующая статистика
по всем квартирам: общая сумма графы «Итого» (формат рублёвый без копеек),
Средняя площадь, Максимальная просрочка.