Основной кабельный модем устанавливает с

Основной кабельный модем устанавливает с регистратором
сети Cisco
Содержание
Введение
Предпосылки
Требования
Используемые компоненты
Соглашения
Топология лаборатории
Предположения
Сетевая диаграмма
Конфигурация регистратора сети Cisco
Конфигурационный файл DOCSIS
Формирование Headend (CMTS)
Формирование CM
Проверка и поиск неисправностей
На CMTS (uBR7246)
На CM (uBR904)
uBR7246
uBR904
Соответствующая информация
Введение
Цель этих технических замечаний состоит в том, чтобы предоставить полному гиду установки для сети кабельного модема (CM) в
окружающей среде лаборатории. Эта установка может использоваться в качестве первого шага перед развертыванием к
потребительской сети. Важно отметить, что безаварийная установка в лаборатории не обязательно означает безаварийную установку в
сети клиента. В окружающей среде лаборатории, которой управляют шум может не быть проблемой; в то время как в реальной жизни,
это может быть как раз наоборот. Однако эта процедура может использоваться для исключения проблем, которые являются
результатом Cisco IOS® Software Release, конфигурации, аппаратных средств и Радиочастоты (RF).
Предпосылки
Требования
Нет никаких определенных требований для этого документа.
Используемые компоненты
Информация в этом документе была создана из устройств в определенной окружающей среде лаборатории. Все устройства,
используемые в этом документе, начали с очищенного (неплатеж) конфигурацию. Если ваша сеть жива, удостоверьтесь, что вы
понимаете потенциальное воздействие любой команды.
Соглашения
Для получения дополнительной информации о соглашениях документа направьте в Cisco Технические Соглашения Подсказок.
Топология лаборатории
Рисунок 1 – установка сети лаборатории
В этой диаграмме существует Система завершения кабельного модема (CMTS), которая состоит из этих компонентов:
uBR7246, который управляет Выпуском 12.1 (2) T программного обеспечения Cisco IOS с Картами Модема MC16C
CM uBR904, который управляет версией 12.0 (7) T Выпуска программного обеспечения Cisco IOS
Upconverter
Фильтр диплекса для отделения высокой частоты от низких частот
Версия 3.5 (3) Регистратора сети Cisco (CNR)
Разделитель с тремя путями
Потребительское оборудование помещения (CPE), которое, в этом случае, является ноутбуком
Примечание: установка RF в той диаграмме может использоваться в качестве стартового ориентира; однако, это могло бы измениться,
как только вы развертываете его в сайте для клиентов. Измерения RF выходят за рамки этого документа; отошлите к Соединению
Серийного маршрутизатора Cisco uBR7200 к Кабелю Headend для надлежащей установки RF и измерений.
Предположения
upconverter уже устанавливается и формируется должным образом. Обратитесь к документации продавца для установки.
Помните, что при использовании GI upconverter это должно быть установлено в на 1.75 МГц ниже, чем частота центра
рассматриваемого канала NTSC.
Существует должным образом формируемый CPE, который сидит позади CM, определенно для получения IP-адреса через сервер
DHCP.
CNR используется в качестве DHCP и серверов TFTP с тем же самым IP-адресом: 172.17.110.136.
Программное обеспечение сервера Времени суток (ToD) бежит на том же самом сервере NT как CNR.
Секции в этом документе объясняют шаги, которые необходимы для формирования этих компонентов:
Регистратор сети Cisco (CNR)
Конфигурационный файл сервисной спецификации интерфейса данных по кабелю (DOCSIS)
Система завершения кабельного модема (CMTS)
Кабельный модем (CM)
Сетевая диаграмма
Рисунок 2 – Сетевая Диаграмма с IP-адресами и Именами, Используемыми в этих Технических замечаниях
Конфигурация регистратора сети Cisco
Выполните эту процедуру для формирования CNR:
1. Начните CNR из меню Start.
2. На строке меню щелкните вкладкой Add для добавления новой группы.
a. Введите имя группы.
В этом случае IP-адрес используется в качестве имени.
b. Проверьте, что Соединение с этой группой однажды добавило флажок.
c. Нажать OK.
Рисунок 3 – имя группы или окно IP-адреса в CNR
3. Когда вы будете побуждены для Имени пользователя и Пароля, используйте admin и changeme.
Рисунок 4 – имя пользователя и окно пароля в CNR
4. Нажать OK.
Окно появляется, который подобен рисунку 5, который содержит имена или IP-адреса формируемых групп.
Рисунок 5 – менеджер по серверу окно в CNR
5. Дважды щелкните по [email protected], для воспитания Имущественного окна [email protected]
6. Щелкните стратегическим счетом и затем нажмите New, для создания новой политики.
Рисунок 6 – добавление политики под названием “кабельные модемы” и копирование признаков от политики “по
умолчанию”
7. Напечатайте от имени политики.
В этом примере именем являются Кабельные модемы.
8. Если это - новая политика, установите Копию от области до неплатежа.
9. Нажать OK.
10. Нажмите варианты Edit, для определения вариантов DHCP.
Для политики под названием Кабельные модемы добавьте следующие варианты (см. рисунок 7):
dhcp-lease-time активен по умолчанию и набор к 604800 секундам, который является числом секунд через одну неделю.
маршрутизаторами является IP-адрес кабельного интерфейса CMTS, в этом случае 10.1.1.10. Посмотрите Формирование
Headend (CMTS).
возмещенный временем CM с Универсального Скоординированного Времени (UTC; выбор Погашения Времени 2). Это
используется CM для вычисления местного времени для добавления метку времени к журналам ошибок.
IP-адрес приспособленцев для сервера ToD, который является 172.17.110.136.
пакетом-siaddr является IP-адрес сервера TFTP, который является 172.17.110.136.
имя файла пакета является конфигурационным файлом DOCSIS, формируемым с DOCSIS CPE Конфигуратор (только
зарегистрированные клиенты). Этот файл должен проживать в tftpboot справочнике сервера TFTP.
Рисунок 7 – редактирует окно вариантов с признаками, данными политике кабельного модема
Примечание: Гарантируйте, чтобы вы проверили Посылание во флажок клиентов BOOTP, если у вас есть клиенты BOOTP.
Это также настоятельно рекомендовано это, вы проверяете, Всегда посылают во флажок клиентов DHCP.
11. Создайте другую политику, связанную с CPEs позади CM, как ноутбуки, и т.д.
В этом примере название политики является Клиентами Кабельного модема.
Выполните ту же самую процедуру, как использовался для политики Кабельных модемов кроме, на сей раз, набор Копия от
области до политики Кабельных модемов вместо к политике по умолчанию.
Рисунок 8 – добавление политики, названной “клиенты кабельного модема” и копирование признаков от существующей
политики под названием “кабельные модемы”
12. Нажать OK.
13. Нажмите кнопку выбора Edit, для отбора активных вариантов.
14. Для политики CPE удалите все опции из Списка активных пользователей кроме dhcp-lease-time и варианты маршрутизаторов.
Чтобы сделать так, выберите собственность удалить в Списке активных пользователей и щелкнуть кнопкой Remove.
15. Измените IP-адрес для выбора маршрутизаторов к 192.168.1.1, который является вторичным IP-адресом, формируемым на
маршрутизаторе CMTS.
Посмотрите формирование Headend (CMTS).
Рисунок 9 – Добавление IP-адреса для Признака маршрутизаторов, который является Вторичным IP-адресом,
Формируемым в Кабельном Интерфейсе, к которому эта политика Применяется в CMTS
Примечание: Этот пример использует частный IP-адрес в качестве вторичного адреса на CMTS и в политике Клиента Кабельных
модемов. В производственной среде устройства CPE должны использовать общественный IP-адрес, чтобы быть в состоянии
получить доступ к Интернету (если Сетевой перевод адреса [NAT] не используется).
16. Создайте объемы для соединения с Кабельными модемами и политикой Клиентов Кабельного модема.
a. Для создания нового объема нажмите на [email protected] в главном меню, и затем щелкните вкладкой Add.
Это позволит вам добавлять новый объем.
b. Введите имя нового объема и затем выберите соответствующую политику.
В этом примере объем для Кабельных модемов собирается использовать диапазон IP-адресов от 10.1.1.20 до 10.1.1.30.
Рисунок 10 – Объем для Кабельных модемов под названием “Кабельные модемы”
c. Повторите Шаги 16a и 16b для объема Клиентов Кабельного модема.
В этом случае частный диапазон IP-адреса от 192.168.1.20 до 192.168.1.30 используется.
Рисунок 11 – Объем для Оборудования CPE Позади Кабельных модемов, названных “Клиенты Кабельного модема”
d. Объем, используемый для устройств CPE, требует дополнительной конфигурации.
a. После создания объем Клиентов Кабельного модема, необходимо дважды щелкнуть по объему для открытия
диалогового окна, которое показывают в рисунке 12.
Рисунок 12 – окно объема клиентов кабельного модема
b. Щелкните Вкладкой "Дополнительно" для связи вторичного объема с основным объемом.
c. Проверьте Делать этот объем вторичный флажок.
d. Как только выпадающий список показывает чистую стоимость, выберите соответствующий основной объем.
В этом примере отобран объем Кабельных модемов.
Рисунок 13 – создание “вторичного объема” клиентов кабельного модема и связь его к основному объему
17. Наконец, необходимо перезапустить сервер DHCP так, чтобы изменения могли иметь место.
В главном меню выберите [email protected] и щелкните вкладкой Control наверху, для показывания диалогового окна в
рисунке 14. Это диалоговое окно позволяет вам перезагружать сервер DHCP.
Рисунок 14 – перезагружает окно для совершения изменений в CNR
Конфигурационный файл DOCSIS
Следующий шаг, который требуется, чтобы установка Кабельная сеть, должен составить конфигурационный файл. Для кабельного
модема для прибытия онлайн это должно загрузить свой конфигурационный файл через TFTP от сервера DHCP. В примере этого
документа CNR используется для обеспечения и TFTP и серверов DHCP. Отошлите к DHCP и Конфигурационному файлу DOCSIS для
Кабельных модемов (DOCSIS 1.0) для получения дополнительной информации о минимальных требованиях к установке
конфигурационный файл. Файл является установкой любой с сетевым инструментом, DOCSIS CPE Конфигуратор (только
зарегистрированные клиенты), или с загрузкой автономной версии. В На CM (uBR904) часть этого документа, конфигурационный файл
DOCSIS, который используется, называют platinum.cm.
Примечание: Как только конфигурационный файл создан, гарантируйте, что он скопирован к серверу TFTP. В случае сервера CNR
TFTP также необходимо гарантировать, что начат сервер TFTP:
1. Выберите [email protected] и затем щелкните вкладкой Control.
Это поднимает диалоговое окно [email protected] Control, где может быть начат сервер.
2. Функциональность сервера TFTP прочь по умолчанию. Чтобы заставить сервер TFTP запуститься автоматически в программе
начального пуска, начните NRCMD (интерфейс командной строки для CNR) и выпустите эти команды:
server tftp set start-on-reboot=enabled
save
Формирование Headend (CMTS)
Это - базовая конфигурация для CMTS (uBR7246):
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Sydney
!
boot system flash ubr7200-ik1s-mz_121-2_T.bin
no logging buffered
enable password <deleted>
!
no cable qos permission create
!--- Default.
no cable qos permission update
!--- Default.
cable qos permission modems
!--- Default.
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
interface FastEthernet0/0
no ip address
shutdown
half-duplex
!
interface Ethernet1/0
ip address 172.17.110.139 255.255.255.224
!--- The IP address of the interface in the same LAN segment as CNR.
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Ethernet1/4
no ip address
shutdown
!
interface Ethernet1/5
no ip address
shutdown
!
interface Ethernet1/6
no ip address
shutdown
!
interface Ethernet1/7
no ip address
shutdown
!
interface Cable2/0
ip address 192.168.1.1 255.255.255.0 secondary
!--- The secondary IP address is used for the CPE’s scope in CNR.
ip address 10.1.1.10 255.255.255.0
!--- The primary IP address is used for the CM’s scope in CNR.
no keepalive
cable downstream annex B
!--- Default for DOCSIS-compliant cable plants. For EuroDOCSIS, use annex A.
cable downstream modulation 64qam
!--- Default.
cable downstream interleave-depth 32
!--- Default.
cable downstream frequency 451250000
!--- Cosmetic except for the uBR7100. This line has no effect
!--- on Upconverter Frequency. Used as a reminder of the frequency
!--- that is used in the Unconverter.
cable upstream 0 frequency 28000000
!--- Upstream Frequency configuration. This is chosen after a careful
!--- analysis on the noise levels of the return path.
cable upstream 0 power-level 0
no cable upstream 0 shutdown
!--- Enables the upstream 0 port.
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 shutdown
cable dhcp-giaddr policy
!--- Modifies the GIADDR field of DHCPDISCOVER and DHCPREQUEST packets.
cable helper-address 172.17.110.136
!--- Specifies a destination IP address for UDP-broadcast DHCP packets.
!
interface Cable3/0
no ip address
no keepalive
shutdown
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable upstream 0 shutdown
cable upstream 1 shutdown
cable upstream 2 shutdown
cable upstream 3 shutdown
cable upstream 4 shutdown
cable upstream 5 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.110.129
no ip http server
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0
exec-timeout 0 0
password cisco
login
line vty 1 4
password cisco
login
!
end
Формирование CM
Как правило, кабельный модем не требует, чтобы любая пользовательская конфигурация для него прибыла онлайн (кроме фабричных
неплатежей). Это применяется, только если CM должен использоваться в качестве моста. Это - пример uBR конфигурации кабельного
модема, которая получается автоматически, после того, как CM прибывает онлайн:
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
clock timezone - 0
ip subnet-zero
no ip routing
!
!
interface Ethernet0
ip address 10.1.1.25 255.255.255.0
no ip directed-broadcast
no ip route-cache
bridge-group 59
bridge-group 59 spanning-disabled
!
interface cable-modem0
ip address negotiated
no ip directed-broadcast
no ip route-cache
cable-modem downstream saved channel 453000000 20 1
cable-modem mac-timer t2 40000
bridge-group 59
bridge-group 59 spanning-disabled
!
ip default-gateway 10.1.1.10
ip classless
no ip http server
!
!
line con 0
transport input none
line vty 0 4
!
end
Проверка и поиск неисправностей
Эта секция описывает команды, которые могут использоваться для подтверждения правильной операции Кабельной сети.
На CMTS (uBR7246)
Гарантируйте, что кабельные модемы онлайн:
Sydney# show cable modem
Interface
Prim Online
Sid State
Cable2/0/U0 2
online
Timing Rec
Offset Power
2290
-0.25
QoS CPE IP address
MAC address
6
0050.7366.2223
1
10.1.1.25
Если кабельные модемы застревают в государстве init(d), то нет никакой возможности соединения между интерфейсом кабеля
CMTS и Сервером DHCP.
Гарантируйте, что можно выпустить расширенный звон от кабельного интерфейса CMTS:
Sydney# ping ip
Target IP address: 172.17.110.136
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 10.1.1.10
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.110.136, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms
Если звон не успешен, проверьте направление IP. Кроме того, гарантируйте, что сервер NT, который управляет CNR, имеет правильные
ворота по умолчанию или маршрут назад к CMTS. Можно также выпустить звон от CNR.
Другая команда, которая может использоваться на CMTS для подтверждения кабельного модема и возможности соединения CPE,
является выставочным интерфейсным кабелем 2/0 модем 0:
Sydney# show interfaces cable 2/0 modem 0
SID
2
Priv bits
00
Type
host
State
unknown
IP address
192.168.1.20
method
dhcp
MAC address
0010.a4e6.d04d
dhcp
0050.7366.2223
!--- A laptop that is obtaining an IP address.
2
00
modem
up
10.1.1.25
!--- The cable modem.
На CM (uBR904)
Можно также проверить возможность соединения на стороне кабельного модема. Выпустите выставочную укороченную команду
интерфейса IP и проверьте, что интерфейсами является up/up:
Router# show ip interface brief
Interface
Ethernet0
cable-modem0
IP-Address
10.1.1.25
10.1.1.25
OK? Method Status
YES unset up
YES unset up
Protocol
up
up
Router# show controllers cable-modem 0
BCM Cable interface 0:
CM unit 0, idb 0x2010AC, ds 0x86213E0, regaddr = 0x800000, reset_mask 0x80
station address 0050.7366.2223 default station address 0050.7366.2223
PLD VERSION: 32
MAC State is maintenance_state, Prev States = 15
MAC mcfilter 01E02F00 data mcfilter 01000000
MAC extended header ON
DS: BCM 3116 Receiver: Chip id = 2
US: BCM 3037 Transmitter: Chip id = 30AC
Tuner: status=0x00
Rx: tuner_freq 453000000, symbol_rate 5055880, local_freq 11520000
snr_estimate 35210, ber_estimate 0, lock_threshold 26000
QAM in lock, FEC in lock, qam_mode QAM_64
Tx: TX_freq 27984000, power_level 0x30 (24.0 dBmV), symbol_rate 8
(1280000 sym/sec)
DHCP: TFTP server = 172.17.110.136, TOD server = 172.17.110.136
Security server = 0.0.0.0, Timezone Offest = 0
Config filename = platinum.cm
buffer size 1600
RX data PDU ring with 32 entries at 0x202130
rx_head = 0x202168 (7), rx_p = 0x8621418 (7)
RX MAC message ring with 8 entries at 0x202270
rx_head_mac = 0x2022A0 (6), rx_p_Mac = 0x86214BC (6)
TX BD ring with 8 entries at 0x2023A8, TX_count = 0
TX_head = 0x2023C8 (4), head_txp = 0x8621548 (4)
TX_tail = 0x2023C8 (4), tail_txp = 0x8621548 (4)
TX PD ring with 8 entries at 0x202428, TX_count = 0
TX_head_pd = 0x202C28 (4)
TX_tail_pd = 0x202C28 (4)
Global control and status:
global_ctrl_status=0x00
interrupts:
irq_pend=0x0008, irq_mask=0x00F7
Можно также проверить возможность соединения IP. Звон сервер DHCP от CM:
Router# ping 172.17.110.136
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.110.136, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms
uBR7246
Sydney# show version
Cisco Internetwork Operating System Software
IOS (tm) 7200 Software (UBR7200-IK1S-M),
Version 12.1(2)T, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Tue 16-May-00 13:36 by ccai
Image text-base: 0x60008900, data-base: 0x613E8000
ROM: System Bootstrap,
Version 11.1(10) [dschwart 10], RELEASE SOFTWARE (fc1)
BOOTFLASH: 7200 Software (UBR7200-BOOT-M),
Version 12.0(10)SC, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Sydney uptime is 4 days, 40 minutes
System returned to ROM by reload
System image file is "slot0:ubr7200-ik1s-mz_121-2_T.bin"
cisco uBR7223 (NPE150) processor (revision B) with 57344K/8192K bytes of memory.
Processor board ID SAB0249006T
R4700 CPU at 150Mhz, Implementation 33, Rev 1.0, 512KB L2 Cache
3 slot midplane, Version 1.0
Last reset from power-on
Bridging software.
X.25 software, Version 3.0.0.
8 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
2 Cable Modem network interface(s)
125K bytes of non-volatile configuration memory.
1024K bytes of packet SRAM memory.
20480K bytes of Flash PCMCIA card at slot 0 (Sector size 128K).
4096K bytes of Flash internal SIMM (Sector size 256K).
Configuration register is 0x2102
uBR904
Router# show version
Cisco Internetwork Operating System Software
IOS (TM) 900 Software (UBR900-K1OY556I-M),
Version 12.0(7)T, RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Tue 07-Dec-99 02:01 by phanguye
Image text-base: 0x08004000, database: 0x0852E888
ROM: System Bootstrap,
Version 11.2(19980518:195057), RELEASED SOFTWARE
ROM: 900 Software (UBR900-RBOOT-M),
Version 11.3(7)NA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Router
System
System
System
uptime is 1 hour, 6 minutes
returned to ROM by reload at 11:20:43 - Thu Oct 12 2001
restarted at 11:21:53 - Thu Oct 12 2001
image file is "flash:ubr900-k1oy556i-mz.120-7.T.bin"
cisco uBR900 CM (68360) processor (revision D) with 8192K bytes of memory.
Processor board ID FAA0315Q07M
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 Cable Modem network interface(s)
4096K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Boot flash (Read/Write)
Configuration register is 0x2102
Для подробного объяснения об использовании отладок CNR — в случае, если необходимо расследовать проблемы CNR — относятся к
Поиску неисправностей проблем DHCP в Отладках Регистратора Сети Cisco использования Кабельных сетей. Для конфигурации
Класса клиента обратитесь к Формированию Классов клиента.
Соответствующая информация
Поиск неисправностей uBR Кабельные модемы, Не Прибывающие Онлайн ( только зарегистрированные клиенты)
CNR и FAQs DHCP для кабельной окружающей среды
Как Вычислить Шестнадцатеричную Стоимость для Выбора DHCP 2 (погашение времени)
Поиск неисправностей проблем DHCP в Отладках Регистратора Сети Cisco использования Кабельных сетей
Примеры конфигурации и технические примечания
© 1992-2014 Cisco Systems, Inc. Все права защищены.
Дата генерации PDF файла: 25 декабря 2014
http://www.cisco.com/cisco/web/support/RU/103/1030/1030494_basic_bridged_setup.html