Чему будут равны эле мен ты этого мас си ва?

Вариант № 666619
1. За​да​ние 19 № 3394. Значения двух массивов A и B с индексами от 1 до 100 задаются при помощи следующего
фраг​мен​та про​грам​мы:
for i : = 1 to 100 do
A[i] : = i*i;
for i : = 1 to 100 do
B[i] : = A[i]-100;
Сколь​ко по​л о​жи​тель​ных зна​че​ний будет в мас​си​ве B?
1) 0
2) 10
3) 90
4) 91
2. За​да​ние 19 № 3371. В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже
пред​став​л ен фраг​мент этой про​грам​мы, в ко​то​ром зна​че​ния эле​мен​тов мас​си​ва сна​ча​л а за​да​ют​ся, а затем ме​ня​ют​ся.
for i:=0 to 10 do
A[i]:=i-1;
for i:=10 downto 1 do
A[i-1]:=A[i];
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 9 9 9 9 9 9 9 9 9 9 9
2) 0 1 2 3 4 5 6 7 8 9 9
3) 0 1 2 3 4 5 6 7 8 9 10
4) -1 -1 0 1 2 3 4 5 6 7 8
3. За​да​ние 19 № 3380. В программе описан одномерный целочисленный массив A с индексами от 1 до 10. Ниже
пред​став​л ен фраг​мент этой про​грам​мы, в ко​то​ром зна​че​ния эле​мен​тов мас​си​ва сна​ча​л а за​да​ют​ся, а затем ме​ня​ют​ся.
for i:=1 to 10 do
A[i]:=5*i;
for i:=1 to 10 do begin
k:=A[i]-2;
A[10-i+1]:=k;
end;
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 1 6 11 16 21 23 18 13 8 3
2) 3 8 13 18 23 28 33 38 43 48
3) 48 43 38 33 28 23 18 13 8 3
4) 1 6 11 16 21 26 31 36 41 46
20.04.2015
Стр. 1 из 33
4. За​да​ние 19 № 7333. Ниже представлен записанный на разных языках программирования фрагмент одной и той же
программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы
об​ра​б а​ты​ва​ют​ся эле​мен​ты мас​си​ва с ин​дек​са​ми от 1 до 24.
Бей​с ик
n = 24
A(1) = 4
FOR i = 2 TO n
A(i) = 4*A(i–1) MOD 10
NEXT i
Си
n=24;
A[1] = 4;
for (i = 2; i <= n; i++)
A[i] = 4*A[i–1] % 10;
Пас​каль
n:=24;
A[1]:=4;
for i:= 2 to n do begin
A[i] := 4*A[i–1] mod 10;
end;
Ал​го​рит​ми​че​с кий язык
n:=24
A[1] := 4
нц для i от 2 до n
A[i] = mod (4*A[i–1], 10)
кц
Чему будет равно значение элемента A[24] (то есть элемента массива с индексом 24) после выполнения
фраг​мен​та про​грам​мы?
1) 6
2) 2
3) 8
4) 4
5. За​да​ние 19 № 3381. В программе описан одномерный целочисленный массив с индексами от 0 до 10. В
при​ве​ден​ном ниже фраг​мен​те про​грам​мы мас​сив сна​ча​л а за​п ол​ня​е т​ся, а потом из​ме​ня​е т​ся:
for i:=0 to 10 do
A[i]:= i - 1;
for i:=1 to 10 do
A[i-1]:= A[i];
A[10] := 10;
Как из​ме​ня​ют​ся эле​мен​ты этого мас​си​ва?
1) все эле​мен​ты, кроме по​след​не​го, ока​жут​ся равны между собой
2) все эле​мен​ты ока​жут​ся равны своим ин​дек​сам
3) все эле​мен​ты, кроме по​след​не​го, сдви​га​ют​ся на один эле​мент впра​во
4) все эле​мен​ты, кроме по​след​не​го, умень​ша​ют​ся на еди​ни​цу
6. За​да​ние 19 № 3384. В программе описан одномерный целочисленный массив с индексами от 0 до 10 и
целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом
из​ме​ня​е т​ся:
for i:=0 to 10 do A[i]:=i;
for i:=0 to 4 do begin
k:=A[i];
A[i]:=A[i+5];
A[i+5]:=k;
end;
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 5 6 7 8 9 0 1 2 3 4 10
2) 10 9 8 7 6 5 4 3 2 1 0
3) 0 1 2 3 4 5 4 3 2 1 0
4) 1 0 3 2 5 4 7 6 9 8 10
20.04.2015
Стр. 2 из 33
Образовательный портал «РЕШУ ЕГЭ» (http://информатика.решуегэ.рф)
7. За​да​ние 19 № 3369. Значения элементов двухмерного массива A[1..100,1..100] задаются с помощью следующего
фраг​мен​та про​грам​мы:
for i:=1 to 100 do
for k:=1 to 100 do
if i = k then
A[i,k] := 1
else A[i,k] := -1;
Чему равна сумма эле​мен​тов мас​си​ва после вы​п ол​не​ния этого фраг​мен​та про​грам​мы?
1) 0
2) -9800
3) -9900
4) -10000
8. За​да​ние 19 № 7264. Значения элементов двумерного массива А были равны 0. Затем значения некоторых
эле​мен​тов были из​ме​не​ны (см. пред​став​л ен​ный фраг​мент про​грам​мы):
n := 0;
for i:=1 tо 5 do
for j:=1 tо 6-i do begin
n := n + 1;
A[i,j] := n;
end;
Какой эле​мент мас​си​ва будет иметь в ре​зуль​та​те мак​си​маль​ное зна​че​ние?
1) A[1,1]
2) A[1,5]
3) A[5,1]
4) A[5,5]
9. За​да​ние 19 № 6416. В программе описан одномерный целочисленный массив A с индексами от 0 до 10 и
целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках
про​грам​ми​ро​ва​ния.
Бей​с ик
FOR i = 0 TO 10
A(i) = i-1
NEXT i
FOR i = 0 TO 9
A(i) = A(i+1)
NEXT i
A(10) = 10
Си
for (i = 0; i <= 10; i++)
A[i] = i-1;
for (i = 0; i <= 9; i++)
A[i] = A[i+1];
A[10] = 10;
Пас​каль
for i := 0 to 10 do
A[i] := i-1;
for i := 0 to 9 do
A[i] := A[i+1];
A[10] := 10;
Ал​го​рит​ми​че​с кий язык
нц для i от 0 до 10
A[i] := i-1
кц
нц для i от 0 до 9
A[i] := A[i+1]
кц
A[10] := 10
Чему ока​жут​ся равны эле​мен​ты этого мас​си​ва после вы​п ол​не​ния фраг​мен​та про​грам​мы?
1) 9 9 9 9 9 9 9 9 9 9 10
2) 1 2 3 4 5 6 7 8 9 10 10
3) –1 –1 –1 –1 –1 –1 –1 –1 –1 –1 10
4) 0 1 2 3 4 5 6 7 8 9 10
10. За​да​ние 19 № 3376. В программе описан одномерный целочисленный массив с индексами от 0 до 10. В
при​ве​ден​ном ниже фраг​мен​те про​грам​мы мас​сив сна​ча​л а за​п ол​ня​е т​ся, а потом из​ме​ня​е т​ся:
for i:=0 to 10 do
A[i]:= i + 1;
for i:=0 to 10 do
A[i]:= A[10-i];
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 10 9 8 7 6 5 4 3 2 1 0
2) 11 10 9 8 7 6 5 4 3 2 1
3) 11 10 9 8 7 6 7 8 9 10 11
4) 10 9 8 7 6 5 6 7 8 9 10
11. За​да​ние 19 № 3361. Дан фраг​мент про​грам​мы, об​ра​б а​ты​ва​ю​щ ий мас​сив А из 10 эле​мен​тов:
j := 1;
for i:=1 tо 10 do
if A[i] = A[j] then j := i;
s := j;
Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния этого ал​го​рит​ма?
1) 1
2) 10
3) ин​дек​су эле​мен​та, рав​но​го пер​во​му, и име​ю​щ е​му наи​б оль​ший ин​декс
4) ин​дек​су эле​мен​та, рав​но​го по​след​не​му, и име​ю​щ е​му наи​мень​ший ин​декс
12. За​да​ние 19 № 6918. В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже
представлен записанный на разных языках программирования фрагмент одной и той же программы,
об​ра​б а​ты​ва​ю​щ ей дан​ный мас​сив.
Бей​с ик
s=0
n = 10
FOR i = 0 TO n-1
s = s+A(i)-A(i+1)
NEXT i
Си
s = 0;
n=10;
for (i = 0; i <= n-1; i++)
s=s+A[i]-A[i+1];
Пас​каль
s:=0;
n:=10;
for i:=0 to n-1 do begin
s:=s+A[i]-A[i+1];
end;
Ал​го​рит​ми​че​с кий язык
s:=0
n:=10
нц для i от 0 до n-1
s:=s+A[i]-A[i+1]
кц
В начале выполнения этого фрагмента в массиве находились числа 15, 10, 5, 10, 15, 10, 5, 10, 15, 5, 10, т. е.
A[0]=15, A[1]=10 и т. д. Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния дан​ной про​грам​мы?
1) 0
2) 5
3) 10
4) 15
13. За​да​ние 19 № 3362. В программе описан одномерный целочисленный массив с индексами от 0 до 10 и
целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом
из​ме​ня​е т​ся:
for i:=0 to 10 do A[i]:=i;
for i:=0 to 4 do begin
k:=A[2*i];
A[2*i]:=A[2*i+1];
A[2*i+1]:=k;
end;
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 5 6 7 8 9 0 1 2 3 4 10
2) 10 9 8 7 6 5 4 3 2 1 0
3) 0 1 2 3 4 5 4 3 2 1 0
4) 1 0 3 2 5 4 7 6 9 8 10
14. За​да​ние 19 № 3391. Значения элементов двухмерного массива A[1..100,1..100] задаются с помощью следующего
фраг​мен​та про​грам​мы:
for i : = 1 to 100 do
for k : = 1 to 100 do
if i > k then
A[i,k] : = 1
else A[i,k] : = -1;
Чему равна сумма эле​мен​тов мас​си​ва после вы​п ол​не​ния этого фраг​мен​та про​грам​мы?
1) 0
2) 100
3) -100
4) -200
15. За​да​ние 19 № 4583. В программе описан одномерный целочисленный массив с индексами от 0 до n. Ниже
представлен записанный на разных языках программирования фрагмент одной и той же программы,
об​ра​б а​ты​ва​ю​щ ей дан​ный мас​сив:
Бей​сик
Пас​каль
s=0
z = A(n)
FOR i = 1 TO n - 1
IF A(i) < z THEN
s = s + A(i)
NEXT i
A(10)=10
s: = 0;
z: = A[n];
for i: = 0 to n - 1 do
begin
if A[i] < z then
s: = s + A[i];
end
Си
Ал​го​рит​ми​че​ский язык
s = 0;
z = A[n];
for (i = 0; i < n; i++){
if (A[i] < z) s = s + A[i];
}
s: = 0
z: = A[n]
нц для i от 0 до n - 1
если A[i] < z то
s:=s + A[i]
все
кц
Чему будет равно значение переменной s после выполнения данной программы? Ответ должен быть верным при
любых зна​че​ни​я х эле​мен​тов мас​си​ва.
1) Ми​ни​маль​но​му эле​мен​ту в мас​си​ве A
2) Ко​л и​че​ству эле​мен​тов мас​си​ва A, мень​ших по​след​не​го эле​мен​та мас​си​ва
3) Сумме всех эле​мен​тов мас​си​ва А, мень​ших по​след​не​го эле​мен​та мас​си​ва
4) Ин​дек​су пер​во​го эле​мен​та мас​си​ва А, ко​то​рый мень​ше A[n]
16. За​да​ние 19 № 5206. Ниже представлен записанный на разных языках программирования фрагмент одной и той
же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы
об​ра​б а​ты​ва​ют​ся эле​мен​ты мас​си​ва с ин​дек​са​ми от 1 до 10.
Бей​сик
Пас​каль
n = 10
FOR i = 1 ТО n
s = A(n + 1 - i) * (n + 1 - i)
A(n + 1 - i) = A(i) * (n + 1 - i)
A(i) = s
NEXT i
n : = 10;
for i : = 1 to n do begin
s : = A[n + 1 - i] * (n + 1 - i);
A[n + 1 - i] : = A[i] * (n + 1 - i);
A[i] : = s;
end;
Си
Ал​го​рит​ми​че​ский язык
n = 10;
for (i = 1; i <= n; i++){
s = A[n + 1 - i] * (n + 1 - i);
A[n + 1 - i] = A[i] * (n + 1 - i);
A[i] = s;
}
n : = 10
нц для i от 1 до n
s := A[n+1-i]*(n+1-i)
A[n+1-i] := A[i]*(n+1-i)
A[i] := s
кц
Перед началом выполнения фрагмента все элементы массива равны 1. Укажите утверждение, которое будет
верно после вы​п ол​не​ния ука​зан​но​го фраг​мен​та про​грам​мы при из​ме​не​нии ин​дек​са от 1 до 10.
1) зна​че​ния мас​си​ва по​сто​я н​ны
2) зна​че​ния мас​си​ва сна​ча​л а воз​рас​та​ют, а потом убы​ва​ют
3) зна​че​ния мас​си​ва воз​рас​та​ют
4) зна​че​ния мас​си​ва убы​ва​ют
17. За​да​ние 19 № 3378. Значения элементов двухмерного массива A[1..10,1..10] сначала равны 4. Затем выполняется
сле​ду​ю​щ ий фраг​мент про​грам​мы:
for i:=1 to 4 do
for j:=1 to 5 do begin
A[i,j]:=A[i,j]+4;
A[j,i]:=A[j,i]+5;
end;
Сколь​ко эле​мен​тов мас​си​ва будут равны 9?
1) 20
2) 16
3) 5
4) 4
18. За​да​ние 19 № 3382. В программе описан одномерный целочисленный массив с индексами от 0 до 10 и
целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом
из​ме​ня​е т​ся:
for i:=0 to 10 do A[i]:=i;
for i:=0 to 4 do begin
k:=A[10-i];
A[10-i]:=A[i];
k:=A[i];
end;
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 10 9 8 7 6 5 4 3 2 1 0
2) 0 1 2 3 4 5 6 7 8 9 10
3) 0 1 2 3 4 5 4 3 2 1 0
4) 10 9 8 7 6 5 6 7 8 9 10
19. За​да​ние 19 № 5271. Ниже представлен записанный на разных языках программирования фрагмент одной и той
же программы. В программе описан одномерный целочисленный массив А, в представленном фрагменте программы
об​ра​б а​ты​ва​ют​ся эле​мен​ты мас​си​ва с ин​дек​са​ми от 1 до 10.
Бей​сик
n = 10
FOR i = 1 ТО n
А (n+1-i) = 2*A(i)
NEXT i
Пас​каль
n := 10;
for i := 1 to n do begin
A [n+1-i] := 2*A[i];
end;
Си
n = 10;
for (i = 1; i <= n; i++)
A [n+1-i] = 2*A[i];
Ал​го​рит​ми​че​ский
язык
n : = 10
нц для i от 1 до n
A[n+1-i] := 2*A[i]
кц
Перед на​ча​л ом вы​п ол​не​ния фраг​мен​та эле​мен​ты мас​си​ва имеют зна​че​ния со​о т​вет​ствен​но
1, 2, 4, 8, 16, 32, 64, 128, 256, 512, т.е. A[k] = 2 k-1 , k = 1, ..., 10.
Укажите значение, которое после выполнения указанного фрагмента программы имеют два или более
рас​смот​рен​ных в этом фраг​мен​те эле​мен​та мас​си​ва. Если таких чисел не​сколь​ко, ука​жи​те наи​мень​шее из них.
1) та​ко​го зна​че​ния нет
2) 2
3) 8
4) 4
20. За​да​ние 19 № 4685. В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже
представлен записанный на разных языках программирования фрагмент одной и той же программы,
об​ра​б а​ты​ва​ю​щ ей дан​ный мас​сив:
Бей​сик
Пас​каль
s=0
n = 10
FOR i = 1 ТО n
s = s + A(i) - A (i - 1)
NEXT i
s: = 0;
n : = 10 ;
for i : = 1 to n do begin
s : = s + A[i] - A[i-1];
end
Си
Ал​го​рит​ми​че​ский язык
s = 0;
n = 10;
for (i = 1; i <= n; i++){
s = s + A[i] - A[i - 1];
}
s: = 0
n : = 10
нц для i от 1 до n
s := s + A[i] - A[i - 1]
кц
В начале выполнения этого фрагмента в массиве находились числа 0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100, т.е.
А[0]=0, А[1]=10 и т.д. Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния дан​ной про​грам​мы?
1) 10
2) 50
3) 100
4) 110
21. За​да​ние 19 № 4551. В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже
представлен фрагмент этой программы, записанный на разных языках программирования, в котором значения
эле​мен​тов мас​си​ва сна​ча​л а за​да​ют​ся, а затем ме​ня​ют​ся.
Бей​сик
Пас​каль
FOR i=0 TO 10
A(i)=i-1
NEXT i
FOR i=1 TO 10
A(i-1)=A(i)
NEXT i
A(10)=10
for i:=0 to 10 do
A[i]:=i-1;
for i:=1 to 10 do
A[i-1]:=A[i];
A[10]:=10;
Си
Ал​го​рит​ми​че​ский язык
for (i = 0; i <= 10; i++)
A[i]=i-1;
for (i = 1; i <= 10; i++)
A[i-1]=A[i];
A[10]=10;
нц для i от 0 до 10
A[i]:=i-1
кц
нц для i от 1 до 10
A[i-1]:=A[i]
кц
A[10]:=10
Как из​ме​нят​ся эле​мен​ты этого мас​си​ва после вы​п ол​не​ния фраг​мен​та про​грам​мы?
1) все эле​мен​ты, кроме по​след​не​го, ока​жут​ся равны между собой
2) все эле​мен​ты ока​жут​ся равны своим ин​дек​сам
3) все эле​мен​ты, кроме по​след​не​го, будут сдви​ну​ты на один эле​мент впра​во
4) все эле​мен​ты, кроме по​след​не​го, умень​шат​ся на еди​ни​цу
22. За​да​ние 19 № 6494. Ниже приведён фрагмент программы, записанный на четырёх языках программирования.
Массив A целочисленный двумерный. В программе рассмотрен фрагмент массива, соответствующий значениям
ин​дек​сов от 1 до n; n >= 3.
Бей​с ик
FOR i = n TO 1 STEP -1
FOR j = n TO 1 STEP -1
A(i,j) = i-j
NEXT j
NEXT i
Си
for (i = n; i >= 1; i--) {
for (j = n; j >= 1; j--) {
A[i][j] = i-j;
}
}
Пас​каль
for i := n downto 1 do
for j := n downto 1 do
A[i,j] := i-j;
Ал​го​рит​ми​че​с кий язык
нц для i от n до 1 шаг -1
нц для j от n до 1 шаг -1
A[i,j] := i-j
кц
кц
Чему будет равно максимальное из значений элементов рассмотренного фрагмента массива посе выполнения
фраг​мен​та про​грам​мы?
1) n – 1
2) 1– n
3) n
4) 1
23. За​да​ние 19 № 3367. Элементы двухмерного массива A размером 10x10 первоначально были равны 1. Затем
зна​че​ния не​ко​то​рых из них ме​ня​ют с по​мо​щ ью сле​ду​ю​щ е​го фраг​мен​та про​грам​мы:
for n:=1 to 4 do
for k:=1 to n+1 do begin
A[n,k]:=A[n,k]-1;
A[n,k+1]:=A[n,k]-1;
end;
Сколь​ко эле​мен​тов мас​си​ва в ре​зуль​та​те будут равны 0?
1) 0
2) 4
3) 8
4) 16
24. За​да​ние 19 № 3366. В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже
пред​став​л ен фраг​мент этой про​грам​мы, в ко​то​ром зна​че​ния эле​мен​тов мас​си​ва сна​ча​л а за​да​ют​ся, а затем ме​ня​ют​ся.
for i:=0 to 10 do
A[i]:=3*i;
for i:=1 to 10 do
A[i]:=A[i] mod 3;
Чему будут равны эле​мен​ты этого мас​си​ва?
1) Все эле​мен​ты будут равны 3.
2) Все эле​мен​ты будут равны 1.
3) Все эле​мен​ты будут равны 0.
4) Все эле​мен​ты будут равны своим ин​дек​сам.
25. За​да​ние 19 № 6227. В программе описан одномерный целочисленный массив с индексами от 0 до 12. Ниже
представлен записанный на разных языках программирования фрагмент одной и той же программы,
об​ра​б а​ты​ва​ю​щ ей дан​ный мас​сив:
Бей​с ик
Пас​каль
s=0
n = 12
FOR i = 0 TO n
IF A(n–i) – A(i) = A(i) THEN
s = s+3*A(i)
END IF
NEXT i
s := 0;
n := 12;
for i:=0 to n do begin
if A[n–i] – A[i] = A[i] then
s:=s+3*A[i];
end;
Си
Ал​го​рит​ми​че​с кий язык
s = 0;
n = 12;
for (i = 0; i <= n; i++) {
if (A[n–i] – A[i] == A[i])
s = s+3*A[i];
}
s := 0
n := 12
нц для i от 0 до n
если A[n–i] – A[i] = A[i]
то s := s+3*A[i]
все
кц
В начале выполнения этого фрагмента в массиве находились числа 0, 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, 22, 24 т. е.
A[0] = 0, A[1] = 2 и т. д. Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния дан​ной про​грам​мы?
1) 12
2) 24
3) 30
4) 156
26. За​да​ние 19 № 5739. В программе описан одномерный целочисленный массив А с индексами от 0 до 10. Ниже
пред​став​л ен фраг​мент этой про​грам​мы, за​п и​сан​ный на раз​ных язы​ках про​грам​ми​ро​ва​ния.
Бей​сик
Пас​каль
FOR i = 0 TO 9
A(i) = i + 1
NEXT i
t = A(0)
FOR i = 0 TO 8
A(i) = A(i+1)
NEXT i
A(9) = t
for i := 0 to 9 do
A[i] := i+1;
t := A[0]
for i := 0 to 8 do
A[i] := A[i+1];
A[9] := t;
Си
Ал​го​рит​ми​че​ский язык
for (i = 0; i <= 9; i++)
A[i] = i+1;
t = A[0];
for (i = 0; i < 8; i++)
A[i] = A[i+1];
A[9] = t;
нц для i от 0 до 9
A[i] := i+1
кц
t := A[0]
нц для i от 0 до 8
A[i] := A[i+1]
кц
A[9] := t
Чему ока​жут​ся равны эле​мен​ты этого мас​си​ва после вы​п ол​не​ния фраг​мен​та про​грам​мы?
1) 1 2 3 4 5 6 7 8 9 1
2) 1 1 1 1 1 1 1 1 1 1
3) 10 10 10 10 10 10 10 10 10 1
4) 2 3 4 5 6 7 8 9 10 1
27. За​да​ние 19 № 6452. Ниже приведён фрагмент программы, записанный на четырёх языках программирования.
Мас​сив A дву​мер​ный; в про​грам​ме рас​смат​ри​ва​е т​ся его фраг​мент, со​о т​вет​ству​ю​щ ий зна​че​ни​я м ин​дек​сов от 1 до n.
Бей​с ик
FOR i = 1 TO n
c = A(i,i)
A(i,i) = A(i,n–i+1)
A(i,n–i+1) = c
NEXT i
Си
for (i = 1; i <= n; i++) {
c = A[i][i];
A[i][i] = A[i][n-i+1];
A[i][n-i+1] = c;
}
Пас​каль
for i := 1 to n do
begin
c := A[i,i];
A[i,i] := A[i,n–i+1];
A[i,n–i+1] := c
end;
Ал​го​рит​ми​че​с кий язык
нц для i от 1 до n
c := A[i,i]
A[i,i] := A[i,n–i+1]
A[i,n–i+1] := c
кц
Представим рассмотренный фрагмент массива в виде квадратной таблицы, в которой для элемента массива A[i, j]
величина i является номером строки, а величина j — номером столбца, в котором расположен элемент. Тогда данный
ал​го​ритм ме​ня​е т ме​ста​ми
1) два столб​ца в таб​л и​це
2) две стро​ки в таб​л и​це
3) эле​мен​ты двух диа​го​на​л ей таб​л и​цы
4) эле​мен​ты диа​го​на​л и и стро​ки таб​л и​цы
28. За​да​ние 19 № 6983. Ниже представлен записанный на разных языках программирования фрагмент одной и той
же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы
об​ра​б а​ты​ва​ют​ся эле​мен​ты мас​си​ва с ин​дек​са​ми от 1 до 32.
Бей​с ик
s=0
n = 32
FOR i = 2 TO n
s = s+3*(A(i)-A(i-1))
NEXT i
Си
s = 0;
n=32;
for (i = 2; i <= n; i++)
s=s+3*(A[i]-A[i-1]);
Пас​каль
s:=0;
n:=32;
for i:= 2 to n do begin
s:=s+3*(A[i]-A[i-1]);
end;
Ал​го​рит​ми​че​с кий язык
s:=0
n:=32
нц для i от 2 до n
s:= s+3*(A[i]-A[i-1])
кц
В начале выполнения этого в элементе массива с индексом i находилось число i (i = 1, …, 32), т. е. A[1] = 1, A[2] = 2
и т. д. Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния дан​ной про​грам​мы?
1) 93
2) 90
3) 31
4) 30
29. За​да​ние 19 № 7365. Ниже при​ведён фраг​мент про​грам​мы, за​п и​сан​ный на четырёх язы​ках про​грам​ми​ро​ва​ния.
Массив A двумерный; в программе рассматривается его фрагмент, соответствующий значениям каждого индекса
от 1 до 9.
Бей​с ик
FOR n=1 TO 9
FOR k=1 TO 9
A(n,k)=2*n+k
NEXT k
NEXT n
Си
for (n=1;n<=9;n++)
for (k=1;k<=9;k++)
A[n][k]=2*n+k;
Пас​каль
for n:=1 to 9 do
for k:=1 to 9 do
A[n,k]:=2*n+k
Ал​го​рит​ми​че​с кий язык
нц для n от 1 до 9
нц для k от 1 до 9
A[n,k]=2*n+k
кц
кц
Сколько элементов указанного фрагмента массива A будут принимать нечётные значения после выполнения
дан​но​го фраг​мен​та про​грам​мы?
1) 36
2) 40
3) 41
4) 45
30. За​да​ние 19 № 3387. В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже
пред​став​л ен фраг​мент этой про​грам​мы, в ко​то​ром зна​че​ния эле​мен​тов мас​си​ва сна​ча​л а за​да​ют​ся, а затем ме​ня​ют​ся.
for i : = 0 to 10 do
A[i] : = 10-i;
for i : = 0 to 5 do begin
A[10-i] : = A[5-i];
A[5+i] : = A[i];
end;
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 9 8 7 6 5 10 9 8 7 6 10
2) 10 9 8 7 6 5 6 7 8 9 10
3) 10 9 8 7 6 10 9 8 7 6 10
4) 5 6 7 8 9 10 9 8 7 6 5
31. За​да​ние 19 № 3372. Значения двух массивов A и B с индексами от 1 до 100 задаются при помощи следующего
фраг​мен​та про​грам​мы:
for i:=1 to n do
A[i]:=(i-75)*(i-75);
for i:=1 to n do
B[101-i]:=A[i];
Какой эле​мент мас​си​ва B будет наи​б оль​шим?
1) B[1]
2) B[26]
3) B[75]
4) B[100]
32. За​да​ние 19 № 6951. Ниже представлен записанный на разных языках программирования фрагмент одной и той
же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы
об​ра​б а​ты​ва​ют​ся эле​мен​ты мас​си​ва с ин​дек​са​ми от 1 до 21.
Бей​с ик
s=0
n = 21
FOR i = 2 TO n
s = s+2*(A(i)-A(i-1))
NEXT i
Си
s = 0;
n=21;
for (i = 2; i <= n; i++)
s=s+2*(A[i]-A[i-1]);
Пас​каль
s:=0;
n:=21;
for i:= 2 to n do begin
s:=s+2*(A[i]-A[i-1]);
end;
Ал​го​рит​ми​че​с кий язык
s:=0
n:=21
нц для i от 2 до n
s:= s+2*(A[i]-A[i-1])
кц
В начале выполнения этого фрагмента в элементе массива с индексом i находилось число i (i = 1, …, 21), т. е. A[1]
= 1, A[2] = 2 и т. д. Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния дан​ной про​грам​мы?
1) 20
2) 21
3) 40
4) 42
33. За​да​ние 19 № 5835. Ниже при​ведён фраг​мент про​грам​мы, за​п и​сан​ный на четырёх язы​ках про​грам​ми​ро​ва​ния.
Массив А одномерный; в программе рассматривается его фрагмент, соответствующий значениям индекса от 1 до
n.
Бей​с ик
FOR i = 0 to 10
A(i) = i
NEXT i
t = A (0)
FOR i = 1 to 10
A(i-1) = A(i)
NEXT i
A(10) = t
Си
for (i = 0; i <= 10; i++)
A[i] = i;
t = A [0];
for (i = 1; i <= 10; i++)
A[i-1] = A[i];
A[10] = t;
Пас​каль
for i := 0 to 10 do
A[i] := i;
t : = A [0];
for i := 1 to 10 do
A[i-1] := A[i];
A[10] := t;
Ал​го​рит​ми​че​с кий язык
нц для i от 0 до 10
А[i] := i
кц
t := А[0]
нц для i от 1 до 10
А[i-1] := А[i]
кц
А[10] := t
Чему ока​жут​ся равны эле​мен​ты этого мас​си​ва после вы​п ол​не​ния фраг​мен​та про​грам​мы?
1) 1 2 3 4 5 6 7 8 9 10 10
2) 1 2 3 4 5 6 7 8 9 10 0
3) 0 0 0 0 0 0 0 0 0 0 0
4) 10 10 10 10 10 10 10 10 10 10 0
34. За​да​ние 19 № 3355. В программе описан одномерный целочисленный массив с индексами от 0 до 10 и
целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом
из​ме​ня​е т​ся:
for i : = 0 to 10 do A[i] : = i;
for i : = 0 to 4 do begin
k : = A[i];
A[i] : = A[10-i];
A[10-i] : = k;
end;
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 10 9 8 7 6 5 4 3 2 1 0
2) 0 1 2 3 4 5 6 7 8 9 10
3) 0 1 2 3 4 5 4 3 2 1 0
4) 10 9 8 7 6 5 6 7 8 9 10
35. За​да​ние 19 № 3354. В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже
пред​став​л ен фраг​мент этой про​грам​мы, в ко​то​ром зна​че​ния эле​мен​тов мас​си​ва сна​ча​л а за​да​ют​ся, а затем ме​ня​ют​ся.
A[0] : = 1;
for i : = 1 to 10 do
A[i] : = 2+A[i-1];
for i : = 0 to 5 do
A[10-i] : = A[i]-1;
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 1 3 5 7 9 10 8 6 4 2 0
2) 1 3 5 7 9 11 13 15 17 19 21
3) 1 3 5 7 9 11 9 7 5 3 1
4) 1 3 5 7 9 11 8 6 4 3 0
36. За​да​ние 19 № 5387. В программе описан одномерный целочисленный массив А с индексами от 0 до 10. Ниже
пред​став​л ен фраг​мент этой про​грам​мы, за​п и​сан​ный на раз​ных язы​ках про​грам​ми​ро​ва​ния.
Бей​с ик
FOR i = 0 ТО 10
A (i) = i-1
NEXT i
FOR i = 1 TO 10
A(i-1) = A(i)
NEXT i
A(10) = 10
Пас​каль
for i = 0 to 10 do
a[i] := i-1;
for i := 1 to 10 do
a[i-1] := a[i];
a[10] := 10;
Си
for(i = 0; i <= 10; i++)
a[i] = i-1;
for(i = 1; i <= 10; i++)
a[i-1] = a[i];
a[10] = 10;
Ал​го​рит​ми​че​с кий язык
нц для i от 0 до 10
A[i] := i-1
кц
нц для i от 1 до 10
A[i-1] := A[i]
кц
А[10] := 10
Чему ока​жут​ся равны эле​мен​ты этого мас​си​ва после вы​п ол​не​ния фраг​мен​та про​грам​мы?
1) 9 9 9 9 9 9 9 9 9 9 10
2) 1 2 3 4 5 6 7 8 9 10 10
3) -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 10
4) 0 1 2 3 4 5 6 7 8 9 10
37. За​да​ние 19 № 5050. В программе описан одномерный целочисленный массив А, в представленном фрагменте
про​грам​мы об​ра​б а​ты​ва​ют​ся эле​мен​ты мас​си​ва с ин​дек​са​ми от 1 до 10.
n := 10;
for i := 1 to n do begin
A [n+1−i] := 2*A[i] ; end;
Перед началом выполнения фрагмента элементы массива имеют значения соответственно 1, 2, 3, 4, 5, 6, 7, 8, 9,
10, т.е. А[1] = 1; А[2] = 2 и т.д. Укажите значение, которое после выполнения указанного фрагмента программы имеет
два или более рассмотренных в этом фрагменте элемента массива. Если таких чисел несколько, укажите
наи​б оль​шее из них.
1) та​ко​го зна​че​ния нет
2) 10
3) 8
4) 4
38. За​да​ние 19 № 3363. Дан фраг​мент про​грам​мы, об​ра​б а​ты​ва​ю​щ ий двух​мер​ный мас​сив A раз​ме​ром nxn.
for i:=1 to n-1 do
for j:= i+1 to n do
if A[i,1] < A[j,1] then begin
k:=A[i,1];
A[i,1]:=A[j,1];
A[j,1]:=k;
end;
В этом фраг​мен​те:
1) упо​ря​до​чи​ва​е т​ся пер​вая стро​ка мас​си​ва по убы​ва​нию
2) упо​ря​до​чи​ва​е т​ся пер​вый стол​б ец мас​си​ва по убы​ва​нию
3) за​ме​ня​ют​ся эле​мен​ты k-ого столб​ца таб​л и​цы
4) за​ме​ня​ют​ся эле​мен​ты k-ой стро​ки таб​л и​цы
39. За​да​ние 19 № 3389. В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже
пред​став​л ен фраг​мент этой про​грам​мы, в ко​то​ром зна​че​ния эле​мен​тов мас​си​ва сна​ча​л а за​да​ют​ся, а затем ме​ня​ют​ся.
for i : = 0 to 10 do
A[i] : = i;
t : = A[0];
for i : = 1 to 10 do
A[i-1] : = A[i];
A[10] : = t;
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 10 10 10 10 10 10 10 10 10 10
2) 1 2 3 4 5 6 7 8 9 10 0
3) 0 0 0 0 0 0 0 0 0 0
4) 1 2 3 4 5 6 7 8 9 10 1
40. За​да​ние 19 № 3393. Значения элементов двухмерного массива A[1..10,1..10] сначала равны 0. Затем выполняется
сле​ду​ю​щ ий фраг​мент про​грам​мы:
for i : = 1 to 4 do
for j : = 2 to 5 do begin
A[i,j] : = A[i,j]+4;
A[j,i] : = A[j,i]+5;
end;
Сколь​ко эле​мен​тов мас​си​ва будут равны 9?
1) 20
2) 16
3) 9
4) 4
41. За​да​ние 19 № 5303. Ниже представлен записанный на разных языках программирования фрагмент одной и той
же программы. В программе описан одномерный целочисленный массив А, в представленном фрагменте программы
об​ра​б а​ты​ва​ют​ся эле​мен​ты мас​си​ва с ин​дек​са​ми от 1 до 10.
Бей​сик
n = 10
FOR i = 1 ТО n
A (n+1-i) = 2*A(i)
NEXT i
Пас​каль
n := 10;
for i := 1 to n do begin
A [n+1-i] := 2*A[i];
end;
Си
n = 10;
for (i = 1; i <= n; i++)
A [n+1-i] = 2*A[i];
Ал​го​рит​ми​че​ский
язык
n : = 10
нц для i от 1 до n
A[n+1-i] := 2*A[i]
кц
Перед на​ча​л ом вы​п ол​не​ния фраг​мен​та эле​мен​ты мас​си​ва имеют зна​че​ния со​о т​вет​ствен​но
1, 2, 4, 8, 16, 32, 64, 128, 256, 512, т.е. A[k] = 2 k-1 , k = 1, ..., 10.
Укажите значение, которое после выполнения указанного фрагмента программы имеют два или более
рас​смот​рен​ных в этом фраг​мен​те эле​мен​та мас​си​ва. Если таких чисел не​сколь​ко, ука​жи​те наи​б оль​шее из них.
1) та​ко​го зна​че​ния нет
2) 8
3) 32
4) 128
42. За​да​ние 19 № 5082. В программе описан одномерный целочисленный массив А, в представленном фрагменте
про​грам​мы об​ра​б а​ты​ва​ют​ся эле​мен​ты мас​си​ва с ин​дек​са​ми от 1 до 10.
n := 10;
for i := 1 to n do begin
A [n+1-i] := 2*A[i] ; end;
Перед началом выполнения фрагмента элементы массива имеют значения соответственно 2, 4, 6, 8, 10, 12, 14, 16,
18, 20, т.е. А[1] = 2; А[2] = 4 и т.д. Укажите значение, которое после выполнения указанного фрагмента программы
имеют два или более рассмотренных в этом фрагменте элемента массива. Если таких чисел несколько, укажите
наи​б оль​шее из них.
1) 8
2) 16
3) 20
4) та​ко​го зна​че​ния нет
43. За​да​ние 19 № 6570. Ниже приведён фрагмент программы, записанный на четырёх языках программирования.
Мас​сив A од​но​мер​ный; в про​грам​ме рас​смат​ри​ва​е т​ся его фраг​мент, со​о т​вет​ству​ю​щ ий зна​че​ни​я м ин​дек​са от 1 до n.
Бей​с ик
s=0
FOR i = 1 TO n
IF A(i)<0 THEN s = s – A(i)
NEXT i
Си
s = 0;
for (i = 1; i <= n; i++) {
if (A[i] < 0) {
s = s - A[i];
}
}
Пас​каль
s := 0;
for i := 1 to n do
begin
if A[i]<0 then
s := s – A[i]
end;
Ал​го​рит​ми​че​с кий язык
s := 0
нц для i от 1 до n
если A[i]<0 то
s := s – A[i]
все
кц
Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния дан​но​го фраг​мен​та про​грам​мы?
1) мо​ду​л ю суммы всех от​ри​ца​тель​ных эле​мен​тов мас​си​ва A
2) ко​л и​че​ству от​ри​ца​тель​ных эле​мен​тов в мас​си​ве A
3) сумме всех от​ри​ца​тель​ных эле​мен​тов мас​си​ва A
4) сред​не​му ариф​ме​ти​че​ско​му всех от​ри​ца​тель​ных эле​мен​тов в мас​си​ве A
44. За​да​ние 19 № 4842. В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже
представлен записанный на разных языках программирования фрагмент одной и той же программы,
об​ра​б а​ты​ва​ю​щ ей дан​ный мас​сив.
Бей​сик
Пас​каль
s=0
n = 10
FOR i = 1 ТО n
IF i = n - i THEN
s = s + A(i) + A (i + 1)
END IF
NEXT i
s: = 0;
n : = 10 ;
for i : = 1 to n do
begin
if i = n - i then
s : = s + A[i] + A[i + 1];
end
Си
Ал​го​рит​ми​че​ский язык
s = 0;
n = 10;
for (i = 1; i <= n; i++){
if (i == n - i)
s = s + A[i] + A[i + 1];
}
s: = 0
n : = 10
нц для i от 1 до n
если i = n - i
то s := s + A[i] + A[i + 1]
все
кц
В начале выполнения этого фрагмента в массиве находились числа 0, 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, т. е. элемент
А[0]=0, А[1]=2 и т. д. Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния дан​ной про​грам​мы?
1) 0
2) 11
3) 22
4) 110
45. За​да​ние 19 № 3373. В программе описан двухмерный целочисленный массив A [1..6,1..6]. Ниже представлен
фраг​мент этой про​грам​мы, в ко​то​ром из​ме​ня​ют​ся зна​че​ния эле​мен​тов мас​си​ва.
for n:=1 to 6 do
for m:=1 to 6 do
A[n,m]:=A[m,n]+2*n-m;
До выполнения данного фрагмента программы значение A[4,3] было равно 10, а значение A[3,4] было равно 15.
Чему будет равно зна​че​ние A[4,3] после вы​п ол​не​ния этого фраг​мен​та про​грам​мы?
1) 10
2) 15
3) 17
4) 20
46. За​да​ние 19 № 6299. В программе описан одномерный целочисленный массив A с индексами от 0 до 9 и
целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках
про​грам​ми​ро​ва​ния.
Бей​с ик
FOR i = 0 TO 9
A(i) = i+1
NEXT i
t = A(0)
FOR i = 1 TO 9
A(i-1) = A(i)
NEXT i
A(9) = t
Си
for (i = 0; i <= 9; i++)
A[i] = i+1;
t = A[0];
for (i = 1; i <= 9; i++)
A[i-1] = A[i];
A[9] = t;
Пас​каль
for i := 0 to 9 do
A[i] := i+1;
t := A[0];
for i := 1 to 9 do
A[i-1] := A[i];
A[9] := t;
Ал​го​рит​ми​че​с кий язык
нц для i от 0 до 9
A[i] := i+1
кц
t := A[0]
нц для i от 1 до 9
A[i-1] := A[i]
кц
A[9] := t
кц
Чему ока​жут​ся равны эле​мен​ты этого мас​си​ва после вы​п ол​не​ния фраг​мен​та про​грам​мы?
1) 1 2 3 4 5 6 7 8 9 1
2) 1 1 1 1 1 1 1 1 1 1
3) 10 10 10 10 10 10 10 10 10 1
4) 2 3 4 5 6 7 8 9 10 1
47. За​да​ние 19 № 3385. Дан фраг​мент про​грам​мы:
for n : = 1 tо 5 do
for m : = 1 tо 5 do
C[n,m] : = (m – n)*(m – n);
Сколь​ко эле​мен​тов мас​си​ва С будут равны 1?
1) 5
2) 2
3) 8
4) 14
48. За​да​ние 19 № 5238. Ниже представлен записанный на разных языках программирования фрагмент одной и той
же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы
об​ра​б а​ты​ва​ют​ся эле​мен​ты мас​си​ва с ин​дек​са​ми от 1 до 10.
Бей​сик
Пас​каль
n = 10
FOR i = 1 ТО n
s = A(n + 1 - i) * i
A(n + 1 - i) = A(i) * i
A(i) = s
NEXT i
n : = 10;
for i : = 1 to n do begin
s : = A[n + 1 - i] * i;
A[n + 1 - i] : = A[i] * i;
A[i] : = s;
end;
Си
Ал​го​рит​ми​че​ский язык
n = 10;
for (i = 1; i <= n; i++){
s = A[n + 1 - i] * i;
A[n + 1 - i] = A[i] * i;
A[i] = s;
}
n : = 10
нц для i от 1 до n
s : = A[n + 1 - i] * i
A[n + 1 - i] : = A[i] * i
A[i] : = s
кц
Перед началом выполнения фрагмента все элементы массива равны 1. Укажите утверждение, которое будет
верно после вы​п ол​не​ния ука​зан​но​го фраг​мен​та про​грам​мы при из​ме​не​нии ин​дек​са от 1 до 10.
1) зна​че​ния мас​си​ва воз​рас​та​ют
2) зна​че​ния мас​си​ва убы​ва​ют
3) зна​че​ния мас​си​ва по​сто​я н​ны
4) зна​че​ния мас​си​ва сна​ча​л а воз​рас​та​ют, а потом убы​ва​ют
49. За​да​ние 19 № 7196. Ниже при​ведён фраг​мент про​грам​мы, за​п и​сан​ный на четырёх язы​ках про​грам​ми​ро​ва​ния.
Массив A двумерный; в программе рассматривается его фрагмент, соответствующий значениям каждого индекса
от 1 до 9.
Бей​с ик
FOR n=1 TO 9
FOR k=1 TO 9
A(n,k)=n+k+1
NEXT k
NEXT n
Си
for (n=1;n<=9;n++)
for (k=1;k<=9;k++)
A[n][k]=n+k+1;
Пас​каль
for n:=1 to 9 do
for k:=1 to 9 do
A[n,k]:=n+k+1
Ал​го​рит​ми​че​с кий язык
нц для n от 1 до 9
нц для k от 1 до 9
A[n,k]=n+k+1
кц
кц
Сколько элементов указанного фрагмента массива A будут принимать нечётные значения после выполнения
дан​но​го фраг​мен​та про​грам​мы?
1) 36
2) 40
3) 41
4) 45
50. За​да​ние 19 № 3368. Значения элементов двухмерного массива A[1..100,1..100] задаются с помощью следующего
фраг​мен​та про​грам​мы:
for i:=1 to 100 do
for k:=1 to 100 do
if i > k then
A[i,k] := i
else A[i,k] := -k;
Чему равна сумма эле​мен​тов мас​си​ва после вы​п ол​не​ния этого фраг​мен​та про​грам​мы?
1) 5000
2) 0
3) -5000
4) -5050
51. За​да​ние 19 № 3386. В программе описан одномерный целочисленный массив с индексами от 0 до 10 и
целочисленные переменные k, i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом
из​ме​ня​е т​ся:
for i : = 0 to 10 do
A[i] : = i;
for i : = 10 downto 0 do begin
k : = A[10-i];
A[10-i] : = A[i];
A[i] : = k;
end;
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 10 9 8 7 6 5 4 3 2 1 0
2) 0 1 2 3 4 5 6 7 8 9 10
3) 10 9 8 7 6 5 6 7 8 9 10
4) 0 1 2 3 4 5 4 3 2 1 0
52. За​да​ние 19 № 6182. В программе описан одномерный целочисленный массив с индексами от 0 до 12. Ниже
представлен записанный на разных языках программирования фрагмент одной и той же программы,
об​ра​б а​ты​ва​ю​щ ей дан​ный мас​сив:
Бей​с ик
Пас​каль
s=0
n = 12
FOR i = 0 TO n
IF A(n–i) – A(i) = A(i) THEN
s = s+2*A(i)
END IF
NEXT i
s := 0;
n := 12;
for i:=0 to n do begin
if A[n–i] – A[i] = A[i] then
s:=s+2*A[i];
end;
Си
Ал​го​рит​ми​че​с кий язык
s = 0;
n = 12;
for (i = 0; i <= n; i++) {
if (A[n–i] – A[i] == A[i])
s = s+2*A[i];
}
s := 0
n := 12
нц для i от 0 до n
если A[n–i] – A[i] = A[i]
то s := s+2*A[i]
все
кц
В начале выполнения этого фрагмента в массиве находились числа 0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100,
110, 120, т. е. A[0] = 0, A[1] = 10 и т. д. Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния дан​ной про​грам​мы?
1) 60
2) 80
3) 100
4) 780
53. За​да​ние 19 № 3357. Значения элементов двух массивов А и В размером 1 х 100 задаются с помощью следующего
фраг​мен​та про​грам​мы:
for i:=1 tо 100 do
A[i] := 50 – i;
for i:=1 tо 100 do
B[i] := A[i] + 49;
Сколь​ко эле​мен​тов мас​си​ва В будут иметь от​ри​ца​тель​ные зна​че​ния?
1) 1
2) 10
3) 50
4) 100
54. За​да​ние 19 № 4717. В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже
представлен записанный на разных языках программирования фрагмент одной и той же программы,
об​ра​б а​ты​ва​ю​щ ей дан​ный мас​сив:
Бей​сик
Пас​каль
s=0
n = 10
FOR i = 1 ТО n
s = s + A(i) - A (i-1)
NEXT i
s: = 0;
n : = 10 ;
for i : = 1 to n do
begin
s : = s + A[i] - A[i-1];
end
Си
Ал​го​рит​ми​че​ский язык
s = 0;
n = 10;
for (i = 1; i <= n; i++)
{
s = s + A[i] - A[i - 1];
}
s: = 0
n : = 10
нц для i от 1 до n
s := s + A[i] - A[i - 1]
кц
В начале выполнения этого фрагмента в массиве находились числа 0, 2, 4, 6, 8, 10, 12, 14, 16, 18, 20, т.е. А[0]=0,
А[1]=2 и т. д. Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния дан​ной про​грам​мы?
1) 10
2) 20
3) 22
4) 110
55. За​да​ние 19 № 3370. В программе описан одномерный целочисленный массив с индексами от 0 до 10 и
целочисленная переменная i. В приведенном ниже фрагменте программы массив сначала заполняется, а потом
из​ме​ня​е т​ся:
for i:=0 to 10 do A[i]:=i;
for i:=0 to 9 do begin
A[i]:=A[i+1];
end;
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 10 0 1 2 3 4 5 6 7 8 9
2) 1 2 3 4 5 6 7 8 9 10 10
3) 0 0 1 2 3 4 5 6 7 8 9
4) 1 2 3 4 5 6 7 8 9 10 0
56. За​да​ние 19 № 7301. Ниже представлен записанный на разных языках программирования фрагмент одной и той
же программы. В программе описан одномерный целочисленный массив A, в представленном фрагменте программы
об​ра​б а​ты​ва​ют​ся эле​мен​ты мас​си​ва с ин​дек​са​ми от 1 до 25.
Бей​с ик
n = 25
A(1) = 2
FOR i = 2 TO n
A(i) = 2*A(i–1) MOD 10
NEXT i
Си
n=25;
A[1] = 2;
for (i = 2; i <= n; i++)
A[i] = 2*A[i–1] % 10;
Пас​каль
n:=25;
A[1]:=2;
for i:= 2 to n do begin
A[i] := 2*A[i–1] mod 10;
end;
Ал​го​рит​ми​че​с кий язык
n:=25
A[1] := 2
нц для i от 2 до n
A[i] = mod (2*A[i–1], 10)
кц
Чему будет равно значение элемента A[25] (то есть элемента массива с индексом 25) после выполнения
фраг​мен​та про​грам​мы?
1) 6
2) 2
3) 8
4) 4
57. За​да​ние 19 № 3374. Значения двумерного массива задаются с помощью вложенного оператора цикла в
пред​став​л ен​ном фраг​мен​те про​грам​мы:
for n:=1 to 5 do
for k:=1 to 5 do
B[n,k] := n + k;
Чему будет равно зна​че​ние B[2,4]?
1) 9
2) 8
3) 7
4) 6
58. За​да​ние 19 № 4930. В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже
пре дста вл е н записанный на разных языках программирования,фрагмент одной и той же программы,
об​ра​б а​ты​ва​ю​щ ей дан​ный мас​сив:
Бей​сик
Пас​каль
s=0
n = 10
FOR i = 0 TO n
IF A(n − i)-A(i) > A(i) THEN
s = s + A(i)
END IF
NEXT i
s := 0;
n := 10;
for i:=0 to n do begin
if A[n - i] - A[i] > A[i] then
s := s + A[i];
end;
Си
Ал​го​рит​ми​че​ский язык
s = 0;
n = 10;
for (i = 0; i <= n; i++ )
if(A[n - i]-A[i] > A[i])
s = s+ A[i];
s := 0
n:=10
нц для i от 0 до n
если A[n - i] - A[i] > A[i]
то s := s + A[i]
все
кц
В начале выполнения этого фрагмента в массиве находились числа 0, 10, 20, 30, 40, 50, 60, 70, 80. 90, 100, т.е. A[0]
= 0, A[1] = 10 и т. д. Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния дан​ной про​грам​мы?
1) 60
2) 100
3) 150
4) 550
59. За​да​ние 19 № 6259. В программе описан одномерный целочисленный массив A с индексами от 0 до 10 и
целочисленная переменная i. Ниже представлен фрагмент этой программы, записанный на разных языках
про​грам​ми​ро​ва​ния.
Бей​с ик
FOR i = 0 TO 10
A(i) = i-1
NEXT i
FOR i = 10 TO 1 STEP -1
A(i) = A(i-1)
NEXT i
Си
for (i = 0; i <= 10; i++)
A[i] = i-1;
for (i = 10; i >= 1; i--)
A[i] = A[i-1];
Пас​каль
for i := 0 to 10 do
A[i] := i-1;
for i := 10 downto 1 do
A[i] := A[i-1];
Ал​го​рит​ми​че​с кий язык
нц для i от 0 до 10
A[i] := i-1
кц
нц для i от 10 до 1 шаг -1
A[i] := A[i-1]
кц
Чему ока​жут​ся равны эле​мен​ты этого мас​си​ва после вы​п ол​не​ния фраг​мен​та про​грам​мы?
1) 0 1 2 3 4 5 6 7 8 9 9
2) 0 1 2 3 4 5 6 7 8 9 10
3) 9 9 9 9 9 9 9 9 9 9 9
4) –1 –1 0 1 2 3 4 5 6 7 8
60. За​да​ние 19 № 6772. Ниже приведён фрагмент программы, записанный на четырёх языках программирования.
Мас​сив A од​но​мер​ный; в про​грам​ме рас​смат​ри​ва​е т​ся его фраг​мент, со​о т​вет​ству​ю​щ ий зна​че​ни​я м ин​дек​са от 1 до n.
Бей​с ик
n = 10
FOR i = 0 TO n
K = A(i)
A(K) = 0
NEXT i
Си
n=10;
for (i = 0; i <= n; i++){
K = A[i];
A[K] = 0;
}
Пас​каль
n:=10;
for i:=0 to n do begin
K := A[i];
A[K] := 0;
end;
Ал​го​рит​ми​че​с кий язык
n:=10
нц для i от 0 до n
K := A[i]
A[K] := 0
кц
В начале выполнения этого фрагмента в массиве находились числа 10, 9, 8, 7, 6, 5, 4, 3, 2, 1, 0, т. е. A[0] = 10, A[1] =
9 и т. д. Сколь​ко эле​мен​тов мас​си​ва после вы​п ол​не​ния про​грам​мы будут иметь не​ну​л е​вые зна​че​ния?
1) 5
2) 2
3) 3
4) 4
61. За​да​ние 19 № 3838. В программе описан одномерный целочисленный массив с индексами от 0 до n (т.е. первый
элемент имеет индекс 0, последний - индекс n). Ниже представлен фрагмент одной и той же программы, записанный
на раз​ных язы​ках про​грам​ми​ро​ва​ния, об​ра​б а​ты​ва​ю​щ ей дан​ный мас​сив:
Бей​сик
Пас​каль
s=n
z = A(0)
FOR i = 1 TO n
IF A(i) = z THEN s = s - 1
NEXT i
s: = n;
z: = A[0];
for i: = 1 to n do
begin
if A[i] = z then
s: = s - 1;
end
Си
Ал​го​рит​ми​че​ский язык
s = n;
z = A[0];
for (i = 1; i <= n; i++){
if (A[i] == z)
s--;
}
s: = n
z: = A[0]
нц для i от 1 до n
если A[i] = z то
s: = s - 1
всекц
Чему будет равно значение переменной s после выполнения данной программы, при любых значениях элементов
мас​си​ва?
1) Ко​л и​че​ству эле​мен​тов мас​си​ва A, боль​ших пер​во​го эле​мен​та мас​си​ва
2) Ко​л и​че​ству эле​мен​тов мас​си​ва A, не пре​вос​хо​дя​щ их пер​во​го эле​мен​та мас​си​ва
3) Ко​л и​че​ству эле​мен​тов мас​си​ва A, не рав​ных пер​во​му эле​мен​ту мас​си​ва
4) Ко​л и​че​ству эле​мен​тов мас​си​ва A, рав​ных пер​во​му эле​мен​ту мас​си​ва
62. За​да​ние 19 № 3359. В программе описан одномерный целочисленный массив с индексами от 0 до 10. В
при​ве​ден​ном ниже фраг​мен​те про​грам​мы мас​сив сна​ча​л а за​п ол​ня​е т​ся, а потом из​ме​ня​е т​ся:
for i:=0 to 10 do
A[i]:= i + 1;
for i:=1 to 10 do
A[i]:= A[i-1];
Как из​ме​ня​ют​ся эле​мен​ты этого мас​си​ва?
1) все эле​мен​ты, кроме по​след​не​го, сдви​га​ют​ся на 1 эле​мент впра​во
2) все эле​мен​ты, кроме пер​во​го, сдви​га​ют​ся на 1 эле​мент влево
3) все эле​мен​ты ока​жут​ся равны 1
4) все эле​мен​ты ока​жут​ся равны своим ин​дек​сам
63. За​да​ние 19 № 3390. Все элементы двумерного массива A размером 10х10 элементов первоначально были равны 0.
Затем значения элементов меняются с помощью вложенного оператора цикла в представленном фрагменте
про​грам​мы:
for n : = 1 to 4 do
for k : = n to 4 do begin
A[n,k] : = A[n,k] + 1;
A[k,n] : = A[k,n] + 1;
end;
Сколь​ко эле​мен​тов мас​си​ва в ре​зуль​та​те будут равны 1?
1) 0
2) 16
3) 12
4) 4
64. За​да​ние 19 № 5707. В программе описаны одномерный целочисленный массив А с индексами от 0 до 10 и
целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках
про​грам​ми​ро​ва​ния.
Бей​сик
Пас​каль
FOR i = 0 TO 10
A(i) = i
NEXT i
t = A(10)
FOR i = 9 TO 0 STEP -1
A(i+1) = A(i)
NEXT i
A(0) = t
for i := 0 to 10 do
A[i] := i;
t := A[10]
for i := 9 downto 0 do
A[i+1] := A[i];
A[0] := t;
Си
Ал​го​рит​ми​че​ский язык
for (i = 0; i <= 10; i++)
A[i] = i;
t = A[10];
for (i = 9; i >= 0; i--)
A[i+1] = A[i];
A[0] = t;
нц для i от 0 до 10
A[i] := i
кц
t := A[10]
нц для i от 9 до 0 шаг -1
A[i+1] := A[i]
кц
A[0] := t
Чему ока​жут​ся равны эле​мен​ты этого мас​си​ва после вы​п ол​не​ния фраг​мен​та про​грам​мы?
1) 10 0 0 0 0 0 0 0 0 0 0
2) 10 2 3 4 5 6 7 8 9 10 10
3) 10 10 10 10 10 10 10 10 10 10 10
4) 10 0 1 2 3 4 5 6 7 8 9
65. За​да​ние 19 № 3379. Элементы двухмерного массива A размером NxN первоначально были равны 1000. Затем
зна​че​ния не​ко​то​рых из них ме​ня​ют с по​мо​щ ью сле​ду​ю​щ е​го фраг​мен​та про​грам​мы:
k := 0;
for i:=1 to N do
for j:=N-i+1 to N do begin
k:= k + 1;
A[i,j]:= k;
end;
Какой эле​мент мас​си​ва в ре​зуль​та​те будет иметь ми​ни​маль​ное зна​че​ние?
1) A[1,1]
2) A[1,N]
3) A[N,1]
4) A[N,N]
66. За​да​ние 19 № 3356. В программе описан одномерный целочисленный массив с индексами от 0 до 10. В
при​ве​ден​ном ниже фраг​мен​те про​грам​мы мас​сив сна​ча​л а за​п ол​ня​е т​ся, а потом из​ме​ня​е т​ся:
for i : = 0 to 10 do
A[i] : = i;
for i : = 1 to 11 do
A[i-1] : = A[11-i];
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 10 9 8 7 6 5 4 3 2 1 0
2) 11 10 9 8 7 6 5 4 3 2 1
3) 10 9 8 7 6 5 6 7 8 9 10
4) 11 10 9 8 7 6 7 8 9 10 11
67. За​да​ние 19 № 3365. Дан фраг​мент про​грам​мы, об​ра​б а​ты​ва​ю​щ ей двух​мер​ный мас​сив A[1..5,1..4]:
k:=4;
for m:=1 to 4 do begin
k:=k+1;
for n:=1 to 5 do begin
k:=m-k;
A[n,m]:=n*n+m*m-2*k;
end;
end;
Чему будет равно зна​че​ние A[3,1]?
1) 18
2) 19
3) 20
4) 21
68. За​да​ние 19 № 6331. В программе описан одномерный целочисленный массив A с индексами от 0 до 10 и
целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках
про​грам​ми​ро​ва​ния.
Бей​с ик
FOR i = 0 TO 10
A(i) = i
NEXT i
t = A(10)
FOR i = 10 TO 1 STEP -1
A(i) = A(i-1)
NEXT i
A(0) = t
Си
for (i = 0; i <= 10; i++)
A[i] = i;
t = A[10];
for (i = 10; i >= 1; i--)
A[i] = A[i-1];
A[0] = t;
Пас​каль
for i := 0 to 10 do
A[i] := i;
t := A[10];
for i := 10 downto 1 do
A[i] := A[i-1];
A[0] := t;
Ал​го​рит​ми​че​с кий язык
нц для i от 0 до 10
A[i] := i
кц
t := A[10]
нц для i от 10 до 1 шаг -1
A[i] := A[i-1]
кц
A[0] := t
кц
Чему ока​жут​ся равны эле​мен​ты этого мас​си​ва после вы​п ол​не​ния фраг​мен​та про​грам​мы?
1) 10 10 10 10 10 10 10 10 10 10 10
2) 10 0 1 2 3 4 5 6 7 8 9
3) 10 0 0 0 0 0 0 0 0 0 0
4) 10 2 3 4 5 6 7 8 9 10 10
69. За​да​ние 19 № 3806. ¬В программе описан одномерный целочисленный массив с индексами от 0 до n. Ниже
представлен фрагмент одной и той же программы, записанный на разных языках программирования,
об​ра​б а​ты​ва​ю​щ ей дан​ный мас​сив:
Бей​сик
Пас​каль
s=0
z = A(n)
FOR i = 0 TO n
IF A(i) > z THEN s = s + 1
NEXT i
s: = 0;
z: = A[n];
for i: = 0 to n do
begin
if A[i] > z then
s: = s + 1;
end
Си
Ал​го​рит​ми​че​ский язык
s = 0;
z = A[n];
for (i = 0; i <= n; i++){
if (A[i] > z)
s++;
}
s: = 0
z: = A[n]
нц для i от 0 до n
если A[i] > z то
s: = s + 1
все
кц
Чему будет равно значение переменной s после выполнения данной программы, при любых значениях элементов
мас​си​ва?
1) Ми​ни​маль​но​му эле​мен​ту в мас​си​ве A
2) Ко​л и​че​ству эле​мен​тов мас​си​ва A, боль​ших по​след​не​го эле​мен​та мас​си​ва
3) Ин​дек​су по​след​не​го эле​мен​та мас​си​ва А, ко​то​рый мень​ше A[0]
4) Ко​л и​че​ству эле​мен​тов мас​си​ва A, мень​ших по​след​не​го эле​мен​та мас​си​ва
70. За​да​ние 19 № 5355. Ниже при​ведён фраг​мент про​грам​мы, за​п и​сан​ный на четырёх язы​ках про​грам​ми​ро​ва​ния.
Массив А одномерный; в программе рассматривается его фрагмент, соответствующий значениям индекса
от 1 до n.
Бей​с ик
J=1
FOR I = 1 to n
IF A(I) < A(J) THEN J = I
NEXT I
s=J
Си
j = 1;
for (i = 1; i <= n; i++) {
if (A[i] < A[j]){
j = i;
}
}
s = j;
Пас​каль
j := 1;
for i := 1 to n do
begin
if A[i] < A[j] then
j := i
end;
s := j;
Ал​го​рит​ми​че​с кий язык
j := 1
нц для i от 1 до n
если A[i] < A[j] то
j := i
все
кц
s := j
Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния дан​но​го фраг​мен​та про​грам​мы?
1) индексу минимального элемента в массиве А (наименьшему из таких индексов, если минимальных элементов
не​сколь​ко)
2) ми​ни​маль​но​му эле​мен​ту в мас​си​ве А
3) ко​л и​че​ству эле​мен​тов, рав​ных ми​ни​маль​но​му в мас​си​ве А
4) индексу минимального элемента в массиве А (наибольшему из таких индексов, если минимальных элементов
не​сколь​ко)
71. За​да​ние 19 № 5451. В программе описаны одномерный целочисленный массив А с индексами от 0 до 9 и
целочисленные переменные i и t. Ниже представлен фрагмент этой программы, записанный на разных языках
про​грам​ми​ро​ва​ния.
Бей​сик
Пас​каль
FOR i = 0 TO 9
A(i) = i + 1
NEXT i
t = A(9)
FOR i = 8 TO 0 STEP -1
A(i+1) = A(i)
NEXT i
A(0) = t
for i := 0 to 9 do
A[i] := i+1;
t := A[9]
for i := 8 downto 0 do
A[i+1] := A[i];
A[0] := t;
Си
Ал​го​рит​ми​че​ский язык
for (i = 0; i <= 9; i++)
A[i] = i+1;
t = A[9];
for (i = 8; i >= 0; i--)
A[i+1] = A[i];
A[0] = t;
нц для i от 0 до 9
A[i] := i+1
кц
t := A[9]
нц для i от 8 до 0 шаг -1
A[i+1] := A[i]
кц
A[0] := t
Чему ока​жут​ся равны эле​мен​ты этого мас​си​ва после вы​п ол​не​ния фраг​мен​та про​грам​мы?
1) 10 3 4 5 6 7 8 9 10 10
2) 10 10 10 10 10 10 10 10 10 10
3) 10 1 1 1 1 1 1 1 1 1
4) 10 1 2 3 4 5 6 7 8 9
72. За​да​ние 19 № 3392. В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже
пред​став​л ен фраг​мент этой про​грам​мы, в ко​то​ром зна​че​ния эле​мен​тов мас​си​ва сна​ча​л а за​да​ют​ся, а затем ме​ня​ют​ся.
for i : = 0 to 10 do
A[i] : = i;
for i : = 0 to 5 do begin
A[10-i] : = A[9-i];
A[i] : = A[i+1];
end;
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 0 1 2 3 4 5 6 7 8 9 10
2) 0 1 2 3 4 5 6 7 8 9 9
3) 1 2 3 4 5 5 5 6 7 8 9
4) 1 2 3 4 5 6 5 4 3 2 1
73. За​да​ние 19 № 6886. В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже
представлен записанный на разных языках программирования фрагмент одной и той же программы,
об​ра​б а​ты​ва​ю​щ ей дан​ный мас​сив.
Бей​с ик
s=0
n = 10
FOR i = 0 TO n-1
s = s+A(i)-A(i+1)
NEXT i
Си
s = 0;
n=10;
for (i = 0; i <= n-1; i++)
s=s+A[i]-A[i+1];
}
Пас​каль
s:=0;
n:=10;
for i:=0 to n-1 do begin
s:=s+A[i]-A[i+1];
end;
Ал​го​рит​ми​че​с кий язык
s:=0
n:=10
нц для i от 0 до n-1
s:=s+A[i]-A[i+1]
кц
В начале выполнения этого фрагмента в массиве находились числа 15, 10, 5, 0, 5, 10, 15, 10, 5, 0, 5, т. е. A[0]=15,
A[1]=10 и т. д. Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния дан​ной про​грам​мы?
1) 0
2) 5
3) 10
4) 15
74. За​да​ние 19 № 3364. В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже
пред​став​л ен фраг​мент этой про​грам​мы, в ко​то​ром зна​че​ния эле​мен​тов мас​си​ва сна​ча​л а за​да​ют​ся, а затем ме​ня​ют​ся.
for i:=0 to 10 do
A[i]:=2+i;
for i:=0 to 4 do begin
A[i]:=A[10-i]-1;
A[10-i]:=A[i]+3;
end;
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 11 10 9 8 7 5 6 7 8 9
2) 11 10 9 8 7 7 5 6 7 8 9
3) 11 10 9 8 7 7 10 11 12 13 14
4) 11 10 9 8 7 10 11 12 13 14
75. За​да​ние 19 № 3375. Значения элементов двумерного массива А размером 5x5 задаются с помощью вложенного
цикла в пред​став​л ен​ном фраг​мен​те про​грам​мы:
for i:=1 tо 5 do
for j:=1 tо 5 do begin
A[i,j] := i*j;
end;
Сколь​ко эле​мен​тов мас​си​ва будут иметь зна​че​ния боль​ше 10?
1) 12
2) 8
3) 10
4) 4
76. За​да​ние 19 № 3360. Значения элементов двух массивов A[1..100] и B[1..100] задаются с помощью следующего
фраг​мен​та про​грам​мы:
for n:=1 to 100 do
A[n] := n – 50;
for n:=1 to 100 do
B[101-n]:=A[n]*A[n];
Какой эле​мент мас​си​ва B будет наи​мень​шим?
1) B[1]
2) B[50]
3) B[51]
4) B[100]
77. За​да​ние 19 № 3388. В программе описан одномерный целочисленный массив A с индексами от 0 до 10. Ниже
пред​став​л ен фраг​мент этой про​грам​мы, в ко​то​ром зна​че​ния эле​мен​тов мас​си​ва сна​ча​л а за​да​ют​ся, а затем ме​ня​ют​ся.
for i : = 0 to 10 do
A[i] : = 2*i;
for i : = 0 to 4 do begin
A[10-i] : = A[i]-1;
A[i] : = A[10-i]-1;
end;
Чему будут равны эле​мен​ты этого мас​си​ва?
1) 0 2 4 6 8 10 12 14 16 18 20
2) 19 17 15 13 11 10 -1 1 3 5 7
3) -2 0 2 4 6 10 7 5 3 1 -1
4) -1 1 3 5 7 9 11 13 15 17 19
78. За​да​ние 19 № 4971. В программе описан одномерный целочисленный массив с индексами от 0 до 10. Ниже
пре дста вл е н записанный на разных языках программирования,фрагмент одной и той же программы,
об​ра​б а​ты​ва​ю​щ ей дан​ный мас​сив:
Бей​сик
Пас​каль
s=0
n = 10
FOR i = 0 TO n
IF A(n − i)-A(i) > A(i) THEN
s = s + A(i)
END IF
NEXT i
s := 0;
n := 10;
for i:=0 to n do begin
if A[n - i] - A[i] > A[i] then
s := s + A[i];
end;
Си
Ал​го​рит​ми​че​ский язык
s = 0;
n = 10;
for (i = 0; i <= n; i++ )
if(A[n - i]-A[i] > A[i])
s = s+ A[i];
s := 0
n:=10
нц для i от 0 до n
если A[n - i] - A[i] > A[i]
то s := s + A[i]
все
кц
В на​ча​л е вы​п ол​не​ния этого фраг​мен​та в мас​си​ве на​хо​ди​л ись числа 0,2,4,6,8,10,12,14,16,18,20 т. е. A[0] = 0, A[1] = 2
и т. д. Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния дан​ной про​грам​мы?
1) 12
2) 20
3) 30
4) 110
79. За​да​ние 19 № 3358. Значения двух массивов A[1..100] и B[1..100] задаются с помощью следующего фрагмента
про​грам​мы:
for n:=1 to 100 do
A[n] := n - 10;
for n:=1 to 100 do
B[n] := A[n]*n;
Сколь​ко эле​мен​тов мас​си​ва B будут иметь по​л о​жи​тель​ные зна​че​ния?
1) 10
2) 50
3) 90
4) 100
80. За​да​ние 19 № 5997. Ниже при​ведён фраг​мент про​грам​мы, за​п и​сан​ный на четырёх язы​ках про​грам​ми​ро​ва​ния.
Мас​сив A од​но​мер​ный; в про​грам​ме рас​смат​ри​ва​е т​ся его фрагмент, оответствующий значениям индекса от 1 до n.
Бей​с ик
Пас​каль
J=1
FOR I = 1 TO n
IF A(I) < A(J) THEN J =I NEXT I
s=J
j :=1;
for i: = 0 to n do
begin
if A[i] < A[j] then
j := i
end;
s := j;
Си
Ал​го​рит​ми​че​с кий язык
j = 1;
for (i = 1; i <= n; i++) {
if (A[i] < A[j]) {
j = i;
}
}
s = j;
j := 1
нц для i от 1 до n
если A[i] < A[j] то
j := i
все
кц
s := j
Чему будет равно зна​че​ние пе​ре​мен​ной s после вы​п ол​не​ния дан​но​го фраг​мен​та про​грам​мы?
1) ми​ни​маль​но​му эле​мен​ту в мас​си​ве A
2) индексу минимального элемента в массиве A (наименьшему и з таких индексов, если минимальных элементов
не​сколь​ко)
3) индексу минимального элемента в массиве A (наибольшему и з таких индексов, если минимальных элементов
не​сколь​ко)
4) ко​л и​че​ству эле​мен​тов, рав​ных ми​ни​маль​но​му в мас​си​ве A
81. За​да​ние 19 № 3383. В программе обрабатывается двумерный целочисленный массив A [0..n,0..n]. Первый индекс
эле​мен​та обо​зна​ча​е т номер стро​ки, а вто​рой – номер столб​ца. Дан фраг​мент про​грам​мы:
for i:=0 to n do begin
c:=A[i,n-i];
A[i,n-i]:=A[1,i];
A[1,i]:=c;
end;
Что ме​ня​е т этот фраг​мент про​грам​мы?
1) два столб​ца в таб​л и​це
2) стро​ку и стол​б ец в таб​л и​це
3) эле​мен​ты диа​го​на​л и и стро​ки в таб​л и​це
4) эле​мен​ты диа​го​на​л и и столб​ца в таб​л и​це
82. За​да​ние 19 № 7263. Дан фраг​мент про​грам​мы:
for n:=1 to 6 do
for m:=1 to 5 do begin
C[n,m]:=C[n,m]+(2*n-m);
end;
Чему будет равно зна​че​ние эле​мен​та дву​мер​но​го мас​си​ва С[4,3], если до вы​п ол​не​ния этих ко​манд С[4,3]=10?
1) 5
2) 10
3) 15
4) 25
83. За​да​ние 19 № 6804. В программе описан одномерный целочисленный массив с индексами от 0 до 9. Ниже
представлен записанный на разных языках программирования фрагмент одной и той же программы,
об​ра​б а​ты​ва​ю​щ ей дан​ный мас​сив.
Бей​с ик
n=9
FOR i = 0 TO n
K = A(i)
A(K) = 0
NEXT i
Си
n=9;
for (i = 0; i <= n; i++){
K = A[i];
A[K] = 0;
}
Пас​каль
n:=9;
for i:=0 to n do begin
K := A[i];
A[K] := 0;
end;
Ал​го​рит​ми​че​с кий язык
n:=10
нц для i от 0 до n
K := A[i]
A[K] := 0
кц
В на​ча​л е вы​п ол​не​ния этого фраг​мен​та в мас​си​ве на​хо​ди​л ись числа 9, 8, 7, 6, 5, 4, 3, 2, 1, 0, т. е. A[0] = 9, A[1] = 8 и т.
д. Сколь​ко эле​мен​тов мас​си​ва после вы​п ол​не​ния про​грам​мы будут иметь не​ну​л е​вые зна​че​ния?
1) 5
2) 2
3) 3
4) 4