close

Вход

Забыли?

вход по аккаунту

- Cisco Connect

код для вставкиСкачать
Эволюция технологий для организации
сервисных цепочек в ЦОД
Хаванкин Максим
cистемный архитектор
[email protected]
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
Legal Disclaimer
Некоторые сведения, приведенные в данной Презентации, могут
представлять ссылки на технологии, которые будут разработаны в будущем,
функциональные возможности, которые будут реализованы в будущем,
ценовую политику для технологических решений и другую подробную
информацию ("Подробные сведения"). Все Подробные сведения приводятся
исключительно в информационных целях и могут быть изменены без
уведомления, включая возможность прекращения разработки (если это
применимо), но не ограничиваясь ей. Cisco Systems не берет на себя
никаких обязательств по окончательной реализации Подробных Сведений и
не будет нести никакую ответственность за их реализацию. Отсутствие
такой реализации не является основанием для возврата ранее
приобретенного оборудования или услуг Cisco Systems.
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
Содержание
§  Введение
§  Организация сервисных цепочек в виртуализированной среде - vPath
§  Подключение сервисных устройств к DFA
§  Интеграция сервисных устройств с ACI
§  Архитектура Network Service Header
§  Заключение
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
Сложности при интеграции сервисов
в существующие ЦОД
Настройка сети для подключения МСЭ
VLAN 10
10.0.10.0/28
Настройка сетевых параметров МСЭ
VLAN 11
10.0.11.0/28
Настройка правил на МСЭ
PBR
VLAN 12
10.0.12.0/24
SNAT
VLAN 13
10.0.13.0/24
Серверы
Вставка сервиса в традиционных
сетях
Настройка сетевых параметров балансировщика
Перенаправление трафика на балансировщик
Настройка балансировщика
4
Вставка сервиса
занимает дни
Настройка сети
занимает время и
является возможным
источником ошибок
Сложности в
отслеживании
изменений
Решает ли проблему сложности тотальная
виртуализация?
Virtual router
Configure Network to insert Firewall
VXLAN 10
10.0.10.0/28
Virtual FW
VXLAN 11
10.0.11.0/28
Virtual ADC
Virtual router
PBR
VXLAN 12
10.0.12.0/24
SNAT
Virtual switch
VXLAN 13
10.0.13.0/24
Configure firewall rules
Упростится ли решаемая
задача, если для вставки
виртуализированного
сервиса применяются те
же сетевые концепции,
что и для физической
сети?
Виртуальные серверы
Вставка сервиса в традиционных
виртуализированных сетях
5
Что делать с распределенными сервисами?
•  Эффект пинг-понга
для сервисных
элементов в
распределенных
ЦОД
L3 ядро
Outside VLAN Inside VLAN VIP
Src-NAT
VIP VLAN Front-­‐end VLAN Subnet A
Subnet A
Back-­‐end VLAN DC-1
DC-2
Сервисные цепочки (SFC) и узлы (SN)
§  Сервисная цепочка – Service Function Chain (SFC)
§  упорядоченный набор сервисных функций (SF)
§  направленный граф в вершинах которого находятся сервисные функции
§  абстракция
§  Сервисный узел – Service Node (SN)
§  устройство, реализующее одну или несколько сервисных функций
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
7
Сервисный путь ( SFP)
§  Сервисный путь – Service Function Path (SFP)
§  конкретная реализация абстрактной сервисной цепочки
§  одной цепочке может соответствовать несколько путей
SF-6.1 и SF-6.2 – два
экземпляра одной
сервисной функции на
разных узлах кластера
сервисных устройств
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
8
Динамический выбор сервисного пути
§  Изменение сервисного пути в зависимости от результатов работы
сервисного устройства
DPI устройство принимает
решение изменить
сервисный путь
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
9
Организация сервисных цепочек в
виртуализированной среде - vPath
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
10
Компоненты коммутатора Nexus 1000V
Модульный коммутатор
M
O
D
E
Supervisor-1
VSM-1
L3
Supervisor-2
VSM-2
MVEM-1
Linecard-1
OVEM-2
Linecard-2
D …
EVEM-N
Linecard-N
VEM-N
VSM: Virtual Supervisor Module
VEM: Virtual Ethernet Module
Устройство Nexus 1100
Управление
Back plane
L2
Виртуальная машина
VSM-1
VSM-2
VEM-2
Гипервизор
Гипервизор
…
VSM-A1
VSM-A6
VSM-B1
VSM-B6
VEM-1
Гипервизор
vPath – перенаправление 1-го пакета каждой новой
сессии на сервисную цепочку
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
4
Nexus 1000V
vPath
Distributed Virtual Switch
Результат
политики в
кеше
Проверка пакета
согласно политике
3
1
Первый
пакет в
сессии
Сервисное
устройство
2
vPath – перенаправление 1-го пакета каждой новой
сессии на сервисную цепочку
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
4
Nexus 1000V
vPath
Distributed Virtual Switch
Результат
политики в
кеше
Проверка пакета
согласно политике
3
1
Первый
пакет в
сессии
Сервисное
устройство
2
vPath – обработка последующих пакетов этого же потока
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
VM
Nexus 1000V
vPath
Distributed Virtual Switch
Результат политики в кеше
определяет дальнейшие
действия Nexus 1000v
Последующие
пакеты к сессии
Сервисное
устройство
Шаг 1: Подготовка N1K и сетевой фабрики к подключению
сервисных виртуальных машин
§  Установить Nexus 1000V
§  Cisco Virtual Switch Update Manager
§  Установить сервисные ВМ с поддержкой vPath
§  PNSC -> VSG, Netscaler, ASAv*
§  Подготовка сетевой фабрики
§  L3 связанность
§  Никаких специальных требований
*roadmap
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
15
Шаг 2: регистрируем сервисные узлы в N1K
vservice node ASA-1 type asa
ip address 10.0.21.1
adjacency l2 vlan 21
fail-mode close
vservice node VSG-1 type vsg
ip address 10.0.21.254
adjacency l2 vlan 21
fail-mode close
switch# show vservice brief
-------------------------------------------------------------------------------License Information
-------------------------------------------------------------------------------Type
In-Use-Lic-Count UnLicensed-Mod
asa
2
-------------------------------------------------------------------------------Node Information
-------------------------------------------------------------------------------ID Name
Type
IP-Address
Mode
State
Module
1 VSG-1
vsg
10.0.21.254
v-21
Alive
4,
2 ASA-1
asa
10.0.21.1
v-21
Alive
4,
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
16
Шаг 3: создаем сервисную цепочку
vservice path WEB-CHAIN
node VSG-1 profile WEB_SP order 1
node ASA-1 profile TEST-EDGE-SP order 3
switch# show vservice brief
<часть вывода опущена>
-------------------------------------------------------------------------------Path Information
-------------------------------------------------------------------------------Name:WEB-CHAIN
NumOfSvc:2 Mod:4,
Node
Order
Profile
VSG-1
1
WEB_SP
ASA-1
3
TEST-EDGE-SP
-------------------------------------------------------------------------------11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
17
Шаг 4: цепочка подключается к профилю
port-profile type vethernet V-CONT.WEB
org root/tenant-01
vservice path WEB-CHAIN
switch# show vservice brief
-------------------------------------------------------------------------------Port Information
-------------------------------------------------------------------------------PortProfile:V-CONT.WEB
Org:root/tenant-01
Path:WEB-CHAIN
Node
Profile(Id)
VSG-1(10.0.21.254)
WEB_SP(9)
ASA-1(10.0.21.1)
TEST-EDGE-SP(8)
Veth Mod VM-Name
vNIC IP-Address
15
4 r1-web-v2
1 10.0.21.10
<часть вывода опущена>
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
18
Шаг 5: настройка политик на сервисных ВМ
§  Традиционный подход к управлению сервисными ВМ
§  Свой CLI/GUI для каждой сервисной функции или группы функций
§  Nexus 1000V или сетевая фабрика не берут на себя функции управления
политиками сервисных устройств
Prime Network
Services Controller
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
19
vPath – основные характеристики
«Разгрузка» обработки с сервисного элемента
vPath
«Разгрузка» обработки с сервисного элемента
Автоматизация
настроек
Да
Фабрика
UCS-D
Гипервизор
VACS
Сервисное устройство
UCS-D, PNSC, VACS
Автоподключение сервисного устройства
Нет
Производители сервисных устройств
Cisco, Citrix, Imperva
Фабрика управляет сервисным устройством
Полностью автоматическая конфигурация
сервисного устройства
Вид цепочки
Нет
Последовательно
Динамический выбор сервисного пути
Нет
Сервисная инкапсуляция
vPath
Поддержка HA сервисных устройств
Да
Scale-out модель для сервисных устройств
Нет
11/20/14
Нет
© 2014 Cisco and/or its affiliates. All rights reserved.
20
vPath – основные характеристики
Автоматизация при помощи Virtual Application Container Services (VACS)
vPath
«Разгрузка» обработки с сервисного элемента
Автоматизация
настроек
Да
Фабрика
UCS-D
Гипервизор
VACS
Сервисное устройство
UCS-D, PNSC, VACS
Автоподключение сервисного устройства
Нет
Производители сервисных устройств
Cisco, Citrix, Imperva
Фабрика управляет сервисным устройством
Полностью автоматическая конфигурация
сервисного устройства
Вид цепочки
Нет
Последовательно
Динамический выбор сервисного пути
Нет
Сервисная инкапсуляция
vPath
Поддержка HA сервисных устройств
Да
Scale-out модель для сервисных устройств
Нет
11/20/14
Нет
© 2014 Cisco and/or its affiliates. All rights reserved.
Развертывание контейнера на базе
Nexus 1000V и vPath в 1-клик
21
vPath – основные характеристики
Собственная сервисная инкапсуляция
vPath
«Разгрузка» обработки с сервисного элемента
Автоматизация
настроек
Да
Фабрика
UCS-D
Гипервизор
VACS
Сервисное устройство
UCS-D, PNSC, VACS
Автоподключение сервисного устройства
Нет
Производители сервисных устройств
Cisco, Citrix, Imperva
Фабрика управляет сервисным устройством
Полностью автоматическая конфигурация
сервисного устройства
Вид цепочки
Нет
Последовательно
Динамический выбор сервисного пути
Нет
Сервисная инкапсуляция
vPath
Поддержка HA сервисных устройств
Да
Scale-out модель для сервисных устройств
Нет
11/20/14
vPath инкапсуляция - проверенный
способ создания сервисных цепочек
Нет
© 2014 Cisco and/or its affiliates. All rights reserved.
22
Подключение сервисных устройств к DFA
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
23
Архитектура Dynamic Fabric Automation
Основные компоненты
Простой модульный набор функций упрощающий развертывание
Управление
фабрикой
Оптимизация
Автоматизация
передачи данных
Оптимизация
Автоматизация
передачи данных
Виртуальные фабрики
24
Архитектура Dynamic Fabric Automation
Подключение сервисных устройств
Точки подключения сервисных
устройств и виртуальных машин
N1KV/OVS N1KV/OVS Виртуальные машины
Физические сервера
FEX-ы, UCS FI, СХД, блейды
Коммутаторы 3-х производителей
Сервисные вирт. машины
Services
WAN/Core
МСЭ
Балансировщики
Устройства 3х производителей
Spine - агрегация
Leaf - доступ
Border Leaf – граница
Services Leaf - сервис
Virtual Leaf - виртуальный
Маршрутизаторы
Коммутаторы
Устройства 3х производителей
Замечание: роли на уровне доступа (leaf) - логические. Один и тот же
коммутатор доступа (leaf) может быть одновременно обычным
коммутатором доступа и сервисным и пограничным.
N1KV/OVS
Шаг 1: подготовка сетевой фабрики
§  Развертывание DFA фабрики при помощи POAP-шаблонов
§  Подключение продуктивной нагрузки
Клиенты
vlan 55
vn-segment 30051
mode fabricpath
interface vlan 55
vrf member INSIDE
ip address 10.10.10.1/24
fabric forwarding mode proxy-gateway
no ip redirects
no shutdown
Core/WAN
BL
Spine
Leaf
Leaf
Spine
VRF: INSIDE
Leaf
www1 - 10.10.10.11
26
Шаг 1: подготовка сетевой фабрики
§  При создании партиции для подключения нагрузки указываем IP адрес
сервисного устройства
§  INSIDE-интерфейс (условно)
IP адрес сервисного
устройства = INSIDE =
Service ES Network
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
27
Шаг 2: создаем виртуальную фабрику для подключения
сервисного устройства
§  Добавляем дополнительный VRF
§  Сервисный узел = маршрутизация между VRF
Клиенты
vlan 55
vn-segment 30051
mode fabricpath
Core/WAN
interface vlan 55
vrf member INSIDE
ip address 10.10.10.1/24
fabric forwarding mode proxy-gateway
no ip redirects
no shutdown
VRF: INSIDE
Spine
Leaf
www1 - 10.10.10.11
Leaf
BL
Spine
Leaf
Leaf
Spine
VRF: OUTSIDE
Leaf
Дополнительный VRF
Spine
Leaf
Сервисное
устройство
28
Шаг 2: создаем виртуальную фабрику для подключения
сервисного устройства
§  Cоздаем в DCNM партицию = VRF для подключения внешнего
интерфейса сервисного устройства
§  Указываем IP адрес сервисного устройства
§  OUTSIDE-интерфейс (условно)
IP адрес сервисного
устройства = OUTSIDE =
External network
29
Шаг 3: создаем профиль автоконфигурации INSIDE
Внутренний интерфейс сервисного устройства
Конфигурация, которая
появится на устройстве
после обнаружения
подключения к фабрике
INSIDE интерфейса
сервисного устройства
Тип подключения = ServiceES Network = внутреннее
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
30
Шаг 4: создаем профиль автоконфигурации OUTSIDE
Внешний интерфейс сервисного устройства
Конфигурация, которая
появится на устройстве
после обнаружения
подключения к фабрике
OUTSIDE интерфейса
сервисного устройства
Тип подключения = External
Network = внешнее
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
31
Шаг 5: Настраиваем маршрутизацию на сервисном
устройстве, например ASA
interface TenGigabitEthernet0/6.20
vlan 20
nameif INSIDE
security-level 100
ip address 10.2.20.1 255.255.255.248
!
interface TenGigabitEthernet0/6.200
vlan 200
nameif OUTSIDE
security-level 0
ip address 10.2.200.1 255.255.255.248
!
router ospf 2
router-id 10.2.20.1
network 10.2.20.0 255.255.255.248 area 0
network 10.2.200.0 255.255.255.248 area 0
log-adj-changes
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
32
Шаг 6: Подключаем сервисное устройство
Автоконфигурация интерфейсов фабрики
vlan 30
vn-segment $segmentId
mode fabricpath
Клиенты
interface vlan 30
vrf member INSIDE
ip address 192.168.30.1/30
ip router ospf 4 area 0.0.0.0
no shutdown
router ospf 4
vrf INSIDE
router-id 192.168.30.1
include profile vrf-common-External-Dynamic
Core/WAN
BL
Spine
Leaf
VRF: INSIDE
Spine
Leaf
11/20/14
www1
- 10.10.10.11
Leaf
Spine
Leaf
© 2014 Cisco and/or its affiliates. All rights reserved.
Leaf
Spine
vlan 41
vn-segment 30041
VRF:
mode OUTSIDE
fabricpath
Leaf interface vlan 41
vrf member OUTSIDE
ip address 192.168.30.5/30
ip router ospf 2 area 0.0.0.0
no shutdown
router ospf 2
vrf OUTSIDE
router-id 192.168.30.5
redistribute direct route-map directMap
redistribute bgp 65002 route-map bgpMap
include
profile vrf-common-ES
33
Сервисное
устройство
Шаг 6: Подключаем сервисное устройство
Конфигурация VRF (на устройстве)
configure profile vrf-common-External-Dynamic!
!
vrf context Red!
vni 50001!
rd auto!
address-family ipv4 unicast!
route-target import 65002:9999!
route-target both auto!
address-family ipv6 unicast!
route-target import 65002:9999!
route-target both auto!
!
router bgp 65002!
vrf Red!
address-family ipv4 unicast!
redistribute hmm route-map FABRIC-RMAPREDIST-HOST!
redistribute direct route-map FABRIC-RMAPREDIST-SUBNET!
maximum-paths ibgp 2!
redistribute ospf 4 route-map ospfMap!
address-family ipv6 unicast!
redistribute hmm route-map FABRIC-RMAPREDIST-HOST!
redistribute direct route-map FABRIC-RMAPREDIST-SUBNET!
maximum-paths ibgp 2!
configure profile vrf-common-ES!
!
vrf context Blue!
vni 50002!
rd auto!
ip route 0.0.0.0/0 192.168.40.2!
address-family ipv4 unicast!
route-target import 65002:9999!
route-target both auto!
address-family ipv6 unicast!
route-target import 65002:9999!
route-target both auto!
!
router bgp 65002!
vrf Blue!
address-family ipv4 unicast!
redistribute hmm route-map FABRIC-RMAPREDIST-HOST!
redistribute direct route-map FABRIC-RMAPREDIST-SUBNET!
maximum-paths ibgp 2!
address-family ipv6 unicast!
redistribute hmm route-map FABRIC-RMAPREDIST-HOST!
redistribute direct route-map FABRIC-RMAPREDIST-SUBNET!
maximum-paths ibgp 2!
Шаг 7: настройка политик на сервисном устройстве
§  Традиционный подход к управлению сервисными устройствами
§  Свой CLI/GUI для каждой сервисной функции или группы функций
§  Сетевая фабрика DFA не берет на себя функции управления политиками
сервисных устройств
Prime Network
Services Controller
11/20/14
Cisco Security
Manager
© 2014 Cisco and/or its affiliates. All rights reserved.
Cisco FireSIGHT
Management Center
35
DFA – основные характеристики
Автоподключение сервисного устройства
DFA
«Разгрузка» обработки с сервисного элемента
Автоматизация
настроек
Нет
Фабрика
DCNM
Гипервизор
UCS-D
Сервисное устройство
UCS-D
Автоподключение сервисного устройства
dot1q, ARP, DHCP, VDP
Производители сервисных устройств
Любой (Routing)
Фабрика управляет сервисным устройством
Полностью автоматическая конфигурация
сервисного устройства
Вид цепочки
Нет
Последовательно
Динамический выбор сервисного пути
Нет
Сервисная инкапсуляция
Нет
Поддержка HA сервисных устройств
Да
Scale-out модель для сервисных устройств
Нет
11/20/14
Автодетекция и подключение любых
сервисных устройств (static, OPSF,
BGP)
Нет
© 2014 Cisco and/or its affiliates. All rights reserved.
36
Интеграция сервисных устройств с ACI
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
37
Основной принцип ACI - логическая конфигурация сети, не
привязанная оборудованию
Вставка сервисной цепочки
App
Web
Внешняя сеть
передачи данных
(Tenant VRF)
DB
QoS
QoS
QoS
Filter
Service
Filter
APIC
ACI фабрика
Неблокируемая фабрика на базе оверлеев
11/20/14
© 2013 Cisco and/or its affiliates. All rights reserved.
38
Application Policy
Infrastructure
Controller
ACI: интеграция с сервисами 4 - 7 уровня
Централизация, автоматизация и поддержка существующей модели
•  Эластичность вставки сервиса
физического или виртуального
Администратор
приложения
Политика
перенаправления
Web
Web
Server
сервер
Stage 1
…..
inst
inst
……..
…
…
Администратор
сервиса
Stage N
inst
inst
МСЭ
Балансировка
end
Сервисный
профиль
begin
Серв.
граф
Определение “Security 5”
•  Автоматизация процесса развертывания/
свертывания сервиса посредством
программируемого интерфейса
•  Применение сервиса вне зависимости от
места нахождения приложения
Web
App
Server
сервер
Сервисная
послед-ть
“Security 5”
•  APIC – центральная точка контроля сети
и согласовании политик
•  Поддержка текущей операционной
модели эксплуатации
App Tier
B
Providers
•  Помощь в административном
разделении между уровнями приложения
и сервиса
App Tier
A
Шаг 1: Научить ACI говорить на языке сетевых сервисов
§ 
Установка “device packages”
§ 
Device packages выпускается вендором сетевого сервиса (F5, Citrix,
etc): кто знает их собственные продукты лучше?
§ 
Нет ограничений на презентацию уникальных для производителя
сервисного устройства функций
§ 
Включает в себя:
§ 
§ 
§ 
Конфигурацию сервисного устройства
Проверку конфигурации на корректность
Мониторинг состояния сервисного устройства
Пример: функции, которые презентуются Citrix NetScaler
§ 
Производитель может презентовать
все функции сервисного устройства
в сторону ACI
§ 
ACI настроит все функции
устройства при помощи скриптов,
которые являются частью integration
package
Шаг 2: Определить «сервисный граф» который можно
использовать повторно
§ 
Определение порядка в котором сервисы должны быть добавлены
при помощи графического интерфейса
§ 
Объект “service graph” может быть использован повторно и
ассоциирован с несколькими приложениями
Параметры, которые могут быть настроены в сервисном
графе
§ 
Эти параметры определяют как будет настроено сервисное
устройство
§ 
Например: алгоритм балансировки нагрузки, виртуальный IP адрес,
и т.д.
Шаг 3: Сообщить ACI как подключиться
к сервисному устройству
Шаг 4: Ассоциировать “сервисный граф” с приложением
§ 
Сервисный граф является частью
контракта, который «заключается»
между EPG (End-Point Group)
§ 
Cервисное устройство
настраивается при помощи
указанных атрибутов при помощи
скриптов, которые являются часть
«device package»
Шаг 5: Подключить серверы к сети
Серверы ассоциируются с End-Point-Group (EPGs) при помощи VLAN,
портовой группы VMware ил AVS на момент FCS. Другие атрибуты – имя
виртуальной машины, DNS или IP адрес/подсеть (roadmap)
Как только сервер попадает в нужный EPG, все необходимое (сетевой QoS,
cетевые ACL, L4-L7 сервисы) настраиваются автоматически
Триггер автоконфигурации политики на сервисном
устройстве = подключение нагрузки, а не сервисного
устройства
Никаких дополнительных действий со стороны администратора
сети и администратора сервисного устройства не требуется
Рендеринг сервисного графа
1
EPG: External Выделение VLAN Настройка VLAN Func9on Firewall Сервисный граф: “web-­‐applicaIon” 2
Func9on SSL offload Func9on Load Balancer EPG: Web 3
4
Firewall 5
Func9on SSL offload Func9on Load Balancer §  Для каждой функции в графе:
1.  APIC выбирает логическое устройство из ранее определенных
2.  APIC разрешает параметры конфигурации и готовит конфигурационный словарь
3.  APIC выделяет VLAN для каждого соединения, ассоциированного с функцией
4.  APIC настраивает сеть - VLAN, EPG и соответствующие фильтры
5.  APIC запускает скрипт и настраивает сервисное устройство
ACI – основные характеристики
OpFlex
ACI
«Разгрузка» обработки с сервисного элемента
Автоматизация
настроек
Нет
Фабрика
APIC
Гипервизор
APIC
Сервисное устройство
APIC
Автоподключение сервисного устройства
APIC
Производители сервисных устройств
Любой (Device pkg.)
Фабрика управляет сервисным устройством
Полностью автоматическая конфигурация
сервисного устройства
Вид цепочки
APIC
Ветвящийся граф
Динамический выбор сервисного пути
Roadmap
Сервисная инкапсуляция
Roadmap
Поддержка HA сервисных устройств
Да
Scale-out модель для сервисных устройств
Roadmap
11/20/14
OpFlex – открытый стандарт,
регламентирующий подключение к
фабрике любых устройств, в т.ч.
сервисных
Opflex (roadmap)
© 2014 Cisco and/or its affiliates. All rights reserved.
48
ACI – основные характеристики
Вид сервисной цепочки
ACI
«Разгрузка» обработки с сервисного элемента
Автоматизация
настроек
Нет
Фабрика
APIC
Гипервизор
APIC
Сервисное устройство
APIC
Автоподключение сервисного устройства
APIC
Производители сервисных устройств
Любой (Device pkg.)
Фабрика управляет сервисным устройством
Полностью автоматическая конфигурация
сервисного устройства
APIC
Opflex (roadmap)
Вид цепочки
Ветвящийся граф
(roadmap)
Динамический выбор сервисного пути
Roadmap
Сервисная инкапсуляция
Roadmap
Поддержка HA сервисных устройств
Да
Scale-out модель для сервисных устройств
Roadmap
11/20/14
Гибкость при выборе топологий =
большое количество сценариев
использования
© 2014 Cisco and/or its affiliates. All rights reserved.
49
Архитектура Network Service Header (NSH)
Перспективная архитектура для следующих поколений существующих
фабрик (см. Legal Disclamer)
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
50
Основные понятия NSH
§  NSH-домен
§  cовокупность сетевых и сервисных устройств, поддерживающих
архитектуру NSH
§  не определяет протоколы плоскости управления
§  NSH Classifier или Service Classifier
§  классификация пакетов на границе домена
§  добавление NSH-заголовка к транспортной инкапсуляции (GRE, VXLAN…)
§  Network Forwarder
§  устройство поддерживающее передачу фреймов с NSH-заголовками
—  понимает, но не разбирает NSH-инкапсуляцию
§  например, Spine устройство фабрики
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
51
Основные понятия NSH
§  Service Function Forwarder (SFF)
§  подключение сервисных устройств,
поддерживающих NSH
§  например, Leaf устройство фабрики
§  SFC Proxy
§  подключение сервисных устройств,
НЕ поддерживающих NSH
§  функция на Leaf устройстве
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
52
Фабрика с поддержкой NSH
NSH-пакет
Пакет c
инкапусляцией
фабрики
NSH-пакет
2
5
9
8
6
3
Исходный пакет
Исходный пакет
1
Исходный пакет
§ 
§ 
§ 
§ 
§ 
§ 
§ 
1-2 native
2-3 TRF+NSH
3-5 native
5-6 TRF+NSH
6-8 TRO+NSH
8-9 TRF
9-10 native
10
7
4
TRF – транспортная инкапсуляция сетевой фабрики
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
TRO – транспортная инкапсуляция за пределами фабрики
53
NSH – плоскость управления
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
54
NSH - инкапсуляция
Фиксированный
заголовок
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
55
NSH – основные характеристики
Сервисная инкапсуляция
NSH
«Разгрузка» обработки с сервисного элемента
Нет
Фабрика
Автоматизация
настроек
Поддержка сервисных путей в
инкапсуляции
Гипервизор
Сервисное устройство
Автоподключение сервисного устройства
Производители сервисных устройств
Определяется
фабрикой
Фабрика управляет сервисным устройством
Полностью автоматическая конфигурация
сервисного устройства
Вид цепочки
Ветвящийся граф
Динамический выбор сервисного пути
Да
Сервисная инкапсуляция
Да
Поддержка HA сервисных устройств
Да
Scale-out модель для сервисных устройств
Да
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
56
NSH – основные характеристики
Динамический выбор сервисного пути
NSH
«Разгрузка» обработки с сервисного элемента
Нет
Фабрика
Автоматизация
настроек
Гипервизор
Сервисное устройств переписывает
NSH-заголовок – изменяет SFP-A на
SFP-B
Сервисное устройство
Автоподключение сервисного устройства
Производители сервисных устройств
Определяется
фабрикой
Фабрика управляет сервисным устройством
Полностью автоматическая конфигурация
сервисного устройства
Вид цепочки
Ветвящийся граф
Динамический выбор сервисного пути
Да
Сервисная инкапсуляция
Да
Поддержка HA сервисных устройств
Да
Scale-out модель для сервисных устройств
Да
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
57
NSH – основные характеристики
Scale-out модель для сервисных устройств
NSH
«Разгрузка» обработки с сервисного элемента
Нет
Фабрика
Автоматизация
настроек
Гипервизор
Облачный подход - эластичный
сервис по запросу
Сервисное устройство
Автоподключение сервисного устройства
Производители сервисных устройств
Определяется
фабрикой
Фабрика управляет сервисным устройством
Полностью автоматическая конфигурация
сервисного устройства
Вид цепочки
Ветвящийся граф
Динамический выбор сервисного пути
Да
Сервисная инкапсуляция
Да
Поддержка HA сервисных устройств
Да
Scale-out модель для сервисных устройств
Да
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
58
Заключение
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
59
Сравнение методов
vPath
DFA
ACI
NSH
Да
Нет
Нет
Нет
Фабрика
UCS-D
DCNM
APIC
Гипервизор
VACS
UCS-D
APIC
Сервисное устройство
UCS-D, PNSC, VACS
UCS-D
APIC
Автоподключение сервисного устройства
Нет
dot1q, ARP, DHCP, VDP
APIC
Производители сервисных устройств
Cisco, Citrix, Imperva
Любой (Routing)
Любой (Device pkg.)
Фабрика управляет сервисным устройством
Полностью автоматическая конфигурация
сервисного устройства
Нет
Нет
APIC
Нет
Нет
Opflex (roadmap)
Вид цепочки
Последовательно
Последовательно
Ветвящийся граф
(roadmap)
Ветвящийся граф
Динамический выбор сервисного пути
Нет
Нет
Roadmap
Да
Сервисная инкапсуляция
vPath
Нет
Roadmap
Да
Поддержка HA сервисных устройств
Да
Да
Да
Да
Scale-out модель для сервисных устройств
Нет
Нет
Roadmap
Да
«Разгрузка» обработки с сервисного элемента
Автоматизация
настроек
11/20/14
© 2014 Cisco and/or its affiliates. All rights reserved.
60
Определяется
фабрикой
Ждем ваших сообщений с хештегом
#CiscoConnectRu
Спасибо
Пожалуйста, заполните анкеты.
Ваше мнение очень важно для нас.
Contacts:
Name Хаванкин Максим
Phone +74999295710
E-mail [email protected]
CiscoRu
11/20/14
Cisco
© 2014 Cisco and/or its affiliates. All rights reserved.
CiscoRussia
1/--страниц
Пожаловаться на содержимое документа