close

Вход

Забыли?

вход по аккаунту

- СВД Встраиваемые Системы

код для вставкиСкачать
«10 шагов для начала разработки в QNX»
Глеб Крылов, СВД Встраиваемые Системы
Шаг 1 - Подготовка
Нам понадобиться:
1)Платформа QNX Software Development Platform, которая содержит набор
инструментов разработчика (QNX Momentics Tool Suite) и операционную систему
реального времени QNX Neutrino .
2)Инструментальный компьютер под управлением ОС Windows/Linux .
Рекомендованные системные требования :
‐ процессор: Pentium 4, 2 Ггц или выше;
‐ ОЗУ: 512 Мб;
‐ пространство на диске: около 4 Гб;
‐ монитор с разрешением 1280x1024.
3)Целевая система.
Процессорная плата ARM, PPC, MIPS, SH‐4, x86 либо виртуальная машина.
4)Соединение по сети.
2
2
Шаг 2 – Установка QNX Momentics Tool
Suite
Установка производиться стандартным образом, через диалог автозапуска CD‐
диска, как для ОС Windows, так и Linux.
Для мастера установки необходимо задать:
‐ лицензионный ключ;
‐ каталог установки;
‐ место расположения проектов (Workspace).
QNX Momentics Tool Suite
3
3
Шаг 3 – Установка ОСРВ QNX Neutrino
Варианты установки ОРСВ QNX Neutrino на целевую систему:
1.Процессорные платы с архитектурой ARM, PPC, MIPS, SH‐4, x86
‐ установка производиться с помощью пакета поддержки оборудования (BSP). Скачать BSP можно на сайте Foundry27 – community.qnx.com
2.Целевая система на базе обычного ПК (x86)
‐ установка производиться с помощью загрузочного СD‐диска QNX SDP, либо
подготовкой загрузочного образа QNX.
3.Виртуальная машина (например: VMware Player)
‐ для установки достаточно скачать и скопировать готовый образ QNX Neutrino
для VMware, на инструментальный компьютер.
Образ QNX Neutrino
для VMware
4
4
Шаг 4 – Настройка соединения по сети
Для удобства разработки, можно соединить по сети инструментальную и
целевую систему. (Узлы должны быть в одной подсети)
TCP/IP
(QNX Neutrino)
IP адрес: 192.168.235.2
(QNX Momentics IDE)
IP адресс: 192.168.235.1
Команда
# ifconfig
позволяет выяснить IP адрес целевой системы:
5
5
Шаг 5 – Взаимодействие по сети
qconn — собственный протокол QNX который обеспечивает удаленное
взаимодействие между инструментальной и целевой системой. Работает поверх
TCP/IP.
Обеспечивает следующие возможности:
‐ получать подробную информацию о целевой системе;
‐ управлять целевой системой;
‐ запускать и отлаживать ПО;
‐ выполнять анализ, как ПО, так и системы в целом
Информация о целевой системе собрана на перспективе QNX Momentics IDE
— Sytem Information.
Управление
qconn
Информация
ОСРВ QNX Neutrino
QNX Momentics IDE
6
6
Шаг 6 – Создание проекта
Проекты (Projects)— являются контейнерами для рабочих файлов в среде
разработки.
Содержат:
‐ файлы исходных кодов С/С++;
‐ заголовочные файлы;
‐ Make‐файлы;
‐ и др. файлы в зависимости от типа проекта.
Мастер создания проекта — вызывается через главное меню
(File > New > QNX C Project). Необходимо задать: ‐ Имя проекта.
‐ Тип проекта: приложение / статическая / динамическая библиотека.
‐ Аппаратную платформу: x86 / ARM / MIPS / PPC / SH.
‐ Дополнительные опции по необходимости.
7
7
Шаг 7 – Компиляция и компоновка
Компиляция и компоновка — выполняется с помощью пункта меню Build Project. В результате получаем:
или
исполняемые файлы
в каталоге проекта Binaries.
перечень ошибок и предупреждений
во вкладке Problems.
8
Шаг 8 – Подготовка к запуску программы
Запуск приложений на целевой системе из IDE, выполняется с помощью
мастера запуска (Launch Configuration).
Необходимо задать:
‐ тип конфигурации С/С++ QNX Qconn (IP);
‐ имя конфигурации (для последующего
использования);
‐ проект и исполняемый файл;
‐ целевую систему;
‐ дополнительные параметры запуска по
необходимости.
9
Шаг 9 – Запуск и отладка
Debug perspective — предоставляет удобный набор инструментов для
проведения отладки.
Позволяет:
‐ отслеживать состояние
переменных;
‐ пошагово исполнять код;
‐ просматривать стек вызовов
функций;
‐ локализовать ошибки.
10
Шаг 10 – Создание собственных
программ
Платформа QNX Software Development Platform помогает разработчикам
создавать приложения для операционной системы реального времени QNX Neutrino.
Позволяет покрывать все этапы разработки: создание кода, отладку, анализ
и интеграцию в конечную систему.
В состав QNX SDP входит:
‐Подробная документация для каждой стадии реализации (Help > Help
Contents).
‐Готовые примеры исходного кода (Help > Welcome > Samples).
Ознакомительная версия QNX SDP:
‐Получить диск сегодня, на семинаре.
‐Скачать на сайте компании QSS:
http://www.qnx.com/products/evaluation/
Глеб Крылов
инженер‐программист
[email protected]
www.kpda.ru
www.swd.ru
1/--страниц
Пожаловаться на содержимое документа