close

Вход

Забыли?

вход по аккаунту

...пространства, рабочего места, перспективы и вида

код для вставкиСкачать
174
проектирование
САПР
Среда разработки CrossCore
Embedded Studio
для процессоров Blackfin и Sharc
компании Analog Devices.
Часть 1. Редактирование исходного
кода и управление проектами
Николай Юрченко
Понятия рабочего пространства,
рабочего места, перспективы
и вида
Прежде чем приступать к написанию
кода, необходимо, во‑первых, разобраться
с основными понятиями среды разработки,
а во‑вторых, научиться в ней ориентировать‑
ся. Первое диалоговое окно, которое вы уви‑
дите при запуске CCES, предложит вам вы‑
брать рабочее пространство (рис. 1). Рабочее
пространство (workplace) — это физическая
папка в вашем компьютере, в которой рас‑
полагаются папки проектов.
Открывшееся после выбора рабочего про‑
странства окно в терминологии CCES называ‑
ется рабочим местом (workbench). На рабочем
месте может находиться одна или несколько
панелей, называемых видами (view). Виды
могут быть объединены в перспективы
(perspective). К примеру, по умолчанию CCES
открывает перспективу «C/C++», предназна‑
ченную для создания и редактирования тек‑
ста программы. На ней открыты виды Project
Explorer, Outline, Console, Problems и другие,
а также редактор исходного кода (рис. 2). При
переходе в режим отладки может быть откры‑
та перспектива Debug, в которую входят виды,
Рис. 1. Выбор рабочего пространства
Мы продолжаем цикл публикаций, посвященных работе с новой средой
разработки и отладки CrossCore Embedded Studio (CCES) для процессоров
семейств Sharc и Blackfin компании Analog Devices. В этой статье рассматриваются вопросы эффективного использования среды для создания
и редактирования исходного кода, а также для управления проектами.
предназначенные для отслеживания процес‑
са исполнения программы, отображения со‑
держимого памяти и регистров и т. д. Также
можно вызвать требуемый в данный момент
вид командой Window → Show View. Любой
из видов может быть расположен и вне глав‑
ного окна CCES, например в виде отдельного
окна на дополнительном мониторе.
Пользователь может вручную переклю‑
чаться между перспективами через подменю
Open Perspective, входящее в меню Window.
Перспективы можно гибко настраивать, меняя
входящие в их состав виды, панели инструмен‑
тов и наборы пунктов меню. Для этого необхо‑
димо выбрать пункт Customize Perspective…
из того же меню Window.
Перспектива «C/C++».
Редактор кода
Как уже было сказано, перспектива
«C/C++» открывается в CCES по умолчанию.
Центральную часть в ней занимает редактор
исходного кода, вобравший в себя все основ‑
ные функции стандартного редактора среды
Eclipse. В частности, он поддерживает под‑
светку синтаксиса, «сворачивание» функций
и циклов, автоматическое завершение ввода,
а также мгновенную подсветку мест, которые
могут при компиляции вызывать ошибку.
По умолчанию в левой части перспективы
«С/C++» расположено окно диспетчера про‑
ектов (Project Explorer), в котором отобража‑
Рис. 2. Окно перспективы «C/C++»
КОМПОНЕНТЫ И ТЕХНОЛОГИИ • № 4 '2013
САПР
проектирование
175
Рис. 3. Внешний вид меню Quick Access
ются такие элементы проектов, как файлы ис‑
ходного кода, заголовочные файлы, файлы,
сгенерированные компилятором и препро‑
цессором, и т. д. Правую часть окна по умолча‑
нию занимает вид Outline, в котором отобра‑
жена структура файла, открытого в данный
момент в редакторе кода. В виде Outline ото‑
бражаются переменные, классы, поля, пере‑
числения, типы данных, структуры, методы,
заголовочные файлы и функции, определен‑
ные в файле исходного кода. Каждый из ти‑
пов объектов, отображенных в виде Outline,
имеет свою иконку для облегчения навигации
по структуре редактируемого файла.
Нижнюю часть экрана в перспекти‑
ве «C/C++» по умолчанию занимает окно
с вкладками Problems, Tasks, Console
и Properties, каждая из которых является так‑
же отдельным видом. Вкладка Problems, как
явствует из названия, предназначена для ото‑
бражения проблем, возникших при компи‑
ляции программы. Вкладка Tasks позволяет
разработчику планировать написание кода,
создавая задачи, которые можно привязывать
к тому или иному объекту для быстрой на‑
вигации. Вкладка Properties дает возможность
отображать свойства файлов и папок проекта.
Вкладка Console — это поток, куда выводят‑
ся сообщения компилятора и препроцессора.
Также по умолчанию в консоль направлены
стандартные потоки stdin и stdout.
Обратите внимание на кнопку Link with
Editor ( ), присутствующую на большин‑
стве видов перспективы «C/C++».
При включении режима Link with Editor
фокус в соответствующем виде будет перене‑
сен на объект, ассоциированный с редактиру‑
емым в данный момент местом программы.
Рис. 4. Окно настройки «горячих» клавиш
ных пунктов меню можно получить быстрый
доступ, нажав Ctrl+3 и введя часть названия
требуемого пункта в строке поиска (рис. 3).
Другой удобной функцией редактора явля‑
ется возможность автоматического завершения
ввода. Для этого необходимо, введя как мини‑
мум первую букву требуемой конструкции, на‑
жать комбинацию клавиш Ctrl+Пробел, после
чего в выпадающем меню выбрать нужный ва‑
риант. К примеру, введя do и использовав авто‑
завершение, можно быстро создать рамочную
конструкцию цикла do while. Шаблоны авто‑
завершения можно создавать самостоятельно,
выбрав пункт меню Window → Preferences → C/C++ → Editor → Templates.
Полный список «горячих» клавиш мож‑
но получить, нажав Ctrl+Shift+L. Обратите
внимание, что, щелкнув по любому из пун‑
ктов списка, соответствующее действие
можно тут же выполнить. Повторное нажа‑
тие Ctrl+Shift+L или же выбор Window → Preferences → Keys открывает окно настрой‑
ки «горячих» клавиш, в котором любому
действию в среде CCES можно назначить
свою комбинацию для быстрого доступа
(рис. 4).
Создание проекта. Настройка
встраиваемых элементов
Наиболее интуитивный способ создать
новый проект в середе CCES — выбрать
File → New… → CrossCore Project. После
ввода названия и выбора типа (исполняемый
файл или статическая библиотека) вновь
создаваемого проекта вам будет предложено
определить, для какой архитектуры (Sharc или
Blackfin) и какой модели процессора будет соз‑
даваться код. Обратите внимание, что в этом
меню можно указать ревизию процессора для
автоматического включения в компиляторе
«обхода» некоторых аномалий кристаллов.
Наиболее часто используемые
«горячие» клавиши
CCES обладает развитой системой «горя‑
чих» клавиш, использование которых заметно
ускоряет работу со средой. К примеру, перей‑
ти к определению функции или переменной
можно, просто щелкнув по ней, держа нажа‑
той клавишу Ctrl. К любому из многочислен‑
КОМПОНЕНТЫ И ТЕХНОЛОГИИ • № 4 '2013
Рис. 5. Окно выбора встраиваемых элементов среды
www.kite.ru
176
проектирование
Следующее окно помощника посвящено
выбору встраиваемых элементов среды для
включения в проект (рис. 5).
Содержание этого списка может отличать‑
ся на вашем компьютере и зависит от уста‑
новленных на нем дополнений. Тем не менее
ряд элементов присутствует в нем по умол‑
чанию. К примеру, по умолчанию в проект
включены код инициализации процессора
и файл линкера (Startup Code/LDF), а также
плагин Pin Multiplexing, генерирующий код
инициализации периферии. Другими эле‑
ментами, которые могут присутствовать
в списке, являются библиотека управления
многоядерными устройствами (MCAPI);
драйверы микросхем и устройств, рас‑
положенных на отладочных платах Analog
Devices: аудиокодеков, ЖКИ, драйверы пери‑
ферийных устройств и системных функций
процессоров, а также операционные систе‑
мы реального времени (ОСРВ), стеки USB,
TCP/IP и т. п.
Последним шагом перед созданием проек‑
та является выбор языка программирования:
C или C++.
Импортирование проекта
в рабочее пространство
Чтобы открыть существующий про‑
ект, необходимо импортировать его в рабо‑
чее пространство. Для этого нужно выбрать
пункт меню File → Import…, а в открыв‑
шемся диалоговом окне — пункт Existing
Project into Workspace (рис. 6).
Обратите внимание, что в отличие
от VisualDSP++ проект в CCES ограничен
папкой, в которой находятся файлы ис‑
ходного кода, заголовочные файлы и т. д.
В рамках одной папки в CCES может нахо‑
диться только один проект, в то время как
в VisualDSP++ несколько файлов .dpj могут
находиться в одной папке и ссылаться на раз‑
личные файлы исходных кодов. Именно
папка целиком импортируется в рабочее
Рис. 6. Окно импорта проектов в рабочее пространство
САПР
пространство CCES, при этом вы можете
выбрать, перемещать ли ее туда физически
или нет.
Также в рабочее пространство мож‑
но импортировать и существующий про‑
ект VisualDSP++. Аналогично импортиро‑
ванию проектов CCES можно запустить
импорт проекта VisualDSP++, выбрав пункт
меню File → Import… и далее в открывшемся
окне VisualDSP++ Project. Помощник импор‑
та при этом преобразует структуру папок про‑
екта в вид, совместимый со CCES и средства‑
ми Eclipse. Однако зачастую для продолжения
работы над проектом, импортированным
из VisualDSP++ в CCES, может потребоваться
изменение исходного кода, а также, возмож‑
но, и файла линкера, так как CCES использу‑
ет несколько измененный набор библиотек
драйверов периферии, системных функций,
управления прерываниями, ОСРВ и т. д.
Использование пакетов
поддержки плат
Рис. 7. Вид окна Project Explorer
Естественно, что многие инженеры начина‑
ют работу с новой для себя архитектурой про‑
цессоров и новой средой разработки с изуче‑
ния примеров кода. В базовый установочный
файл CCES входит небольшой набор приме‑
ров, в основном предназначенных для демон‑
страции работы ядра процессоров Blackfin
и Sharc и работающих с помощью встроен‑
ного симулятора. Дополнительно пользова‑
тель может загрузить так называемые пакеты
поддержки плат (Board Support Package, BSP).
В них входят примеры программ, предна‑
значенные для запуска на той или иной оце‑
ночной плате, предлагаемой Analog Devices
для своих процессоров, а также драйверы для
дополнительных устройств, расположенных
на этой плате, и документация на нее.
Загрузить BSP можно, зайдя на страничку
соответствующей оценочной платы на сайте
Analog Devices.
эти файлы, как правило, находятся в устано‑
вочной папке CCES.
Папка src является физической и содержит
исходный код, созданный пользователем.
Физической является и папка system, которая
содержит драйверы и системные службы,
файлы линкера, а также код, сгенерирован‑
ный автоматизированными средствами кон‑
фигурации процессора, например плагином
Pin Multiplexing.
Debug и Release — физические папки, со‑
держащие объектные файлы, созданные ком‑
пилятором в отладочной или окончательной
конфигурациях соответственно.
Последний элемент списка — файл
system.svc — позволяет вернуться к конфигу‑
рации встраиваемых элементов, описанных
в параграфе, посвященном созданию проекта.
Структура проекта
Заключение
Обратимся вновь к виду окна Project
Explorer, входящего в перспективу «C/C++»
(рис. 7).
Согласно этому окну проект содержит ряд
папок, часть из которых является реальными
папками на жестком диске вашего компьюте‑
ра, а часть — виртуальными, необходимыми
лишь для структурирования представления
элементов проекта.
Папка Binaries является виртуальной и со‑
держит бинарные исполняемые файлы, соз‑
данные компилятором: они имеют расши‑
рение .dxe. Иконка рядом с названием файла
показывает, был ли данный файл скомпили‑
рован в отладочной (Debug) или окончатель‑
ной (Release) редакции.
Папка Includes также является виртуальной
и содержит заголовочные файлы, необходи‑
мые для компиляции проекта. Физически
В статье описаны новые возможно‑
сти среды разработки CCES по сравнению
с VisualDSP++, в частности, расширенный
функционал редактора кода. Даны опреде‑
ления базовым понятиям интерфейса среды,
описана структура проекта и процесс его соз‑
дания и конфигурации.
n
Литература
1. CrossCore Embedded Studio IDE Help.
2. FAQ: What are board support packages, and do
I need one? http://ez.analog.com/docs/DOC-2432
3. FAQ: Imported CCES Example won't build; what is
the procedure to import an example? http://
ez.analog.com/docs/DOC-2403
4. FAQ: Importing VisualDSP++ project files to
CrossCore Embedded Studio http://ez.analog.com/
docs/DOC-2466
КОМПОНЕНТЫ И ТЕХНОЛОГИИ • № 4 '2013
1/--страниц
Пожаловаться на содержимое документа