close

Вход

Забыли?

вход по аккаунту

код для вставкиСкачать
Візуальний редактор вебсайтів
Microsoft FrontPage
Звичайно, було б зручно форматувати веб-сторінки так, як у
текстових процесорах, коли на екрані документ має приблизно
такий самий вигляд, як і після друку. Цей підхід, який
називають WYSIWYG (What Your See Is What Your Get — що
бачиш, те й отримаєш), реалізовано у програмі Microsoft
FrontPage — візуальному редакторі веб-сторінок.
На відміну від більшості текстових редакторів, які виводять на
екран лише теги HTML, FrontPage відразу інтерпретує їх, і ви
бачите сторінку майже такою, як у вікні браузера. Завдяки
цьому відпадає потреба у постійному перемиканні між
браузером та редактором для перегляду веб-сторінки.
У програмі FrontPage є все необхідне для роботи з веб-сайтом:
засіб для навігації FrontPage Explorer, редактор веб-сторінок
FrontPage Editor, засоби для роботи з графікою та публікації
документів.
Вікно програми
На малюнку зображене вікно програми FrontPage 2003. Воно оформлене в
єдиному для всіх програм Microsoft Office 2003 стилі.
У верхній частині вікна міститься рядок меню і дві панелі інструментів —
Стандартная (Стандартна) та Форматирование (Форматування). Основна
частина вікна відведена під робочу область, в якій можна відкрити один
або кілька документів. Внизу розташований рядок стану, що містить
довідкову інформацію.
Програма FrontPage пропонує сім режимів для роботи з вебдокументами. Для переходу у потрібний режим використовують
команди меню Вид (Вигляд), призначення яких описано у таблиці.
У режимі Страница (Сторінка) в нижній частині робочої області є чотири
вкладки, які дають змогу переглядати веб-сторінку в різних режимах.
•Конструктор (Конструктор) — звичайний режим роботи, в якому
створюють або редагують сторінку за допомогою візуальних засобів,
розміщуючи на ній текст, лінії, кнопки, посилання та інші об'єкти.
•Код (Код) — режим перегляду і створення сторінки в HTML- кодах. Його
можна використовувати як для формування сторінки через уведення HTMLкодів у веб-документ, так і для перегляду, редагування та доповнення кодів
сторінки, створеної у звичайному режимі роботи.
•С разделением (З розподілом) — комбінований режим, у якому робоча
область поділена на дві частини: у верхній відображені HTML-коди сторінки,
а в нижній — її вигляд у режимі конструктора.
•Просмотр (Перегляд) — попередній перегляд сторінки у тому вигляді, в
якому вона відображається у вікні браузера.
Відкривання та створення сайтів і веб-сторінок
Для відкриття наявного веб-сайту слід виконати такі дії:
•у меню Файл (Файл) вибрати команду Открыть узел
(Відкрити вузол) або на панелі інструментів Стандартная
(Стандартна) клацнути стрілку праворуч від кнопки
Открыть (Відкрити) і вибрати у меню команду Открыть
узел (Відкрити вузол).
•у вікні Открытие веб-узла (Відкривання веб-вузла)
вибрати папку, в якій розташовано веб-сайт. Клацнути
кнопку Открыть (Відкрити).
За допомогою команди
Файл • Открыть (Файл • Відкрити)
у
програмі
FrontPage
можна
відкривати документи, збережені
на диску у вигляді окремих файлів,
веб-сторінки з Інтернету, а також
сторінки локального веб-сайту — в
останньому випадку буде відкрито
весь відповідний сайт, якщо цього
не було зроблено раніше.
Відкрити веб-сторінку можна ще
у такі способи:
•
на
стандартній
панелі
інструментів
клацнути
кнопку
Открыть(Відкрити);
• клацнути стрілку праворуч від
кнопки
Открыть
(Відкрити)
і
вибрати
в
меню
однойменну
команду;
• натиснути клавіші Ctrl+0.
Щоб створити нову звичайну веб-сторінку, необхідно в меню
файл (Файл) вибрати команду Создать (Створити) і в області
завдань Создание (Створення), що з'явиться, клацнути
посилання Пустая страница (Порожня сторінка). Можна
також просто клацнути кнопку Создание новой обычной
страницы (Створення нової звичайної сторінки) на панелі
інструментів Стандартная (Стандартна).
Форматування тексту
Форматування тексту HTML-документа здебільшого виконують за
допомогою панелі інструментів Форматирование (Форматування), яка
схожа на аналогічну панель програми Word. Але при цьому в текст
вставляються відповідні теги HTML. Наприклад, у разі зміни вигляду,
розміру, кольору шрифту в документ буде вставлено відповідний тег
<FONT>, виділення курсивом і напівжирним шрифтом забезпечують теги
<І> та <В>, а вирівнювання тексту буде задано відповідними атрибутами
тегу <Р>. Використання кнопок для створення списків приводить до
включення у документ відповідних тегів маркованого або нумерованого
списків.
Деяких
засобів
керування
шрифтами
на
панелі
інструментів
Форматирование (Форматування) немає. Для їх застосування слід вибрати
команду Формат • Шрифт (Формат • Шрифт), яка відкриє діалогове вікно,
що дає змогу встановлювати всі параметри символів.
Можна вставляти на сторінку текстові фрагменти, створені в інших
програмах Microsoft Office, оскільки FrontPage розпізнає їхні формати
даних та конвертує їх у HTML-код. Для перенесення тексту
використовують стандартні засоби копіювання (переміщення) тексту
через буфер обміну. FrontPage намагається, наскільки це можливо,
зберегти форматування такого тексту.
Розміщення і настроювання
зображень
Для розміщення на сторінці зображення з файлу слід виконати одну з
таких дій:
• у меню Вставка (Вставка) вибрати команду Рисунок • Из файла
(Малюнок • З файлу);
• клацнути кнопку Добавить рисунок из файла (Додати малюнок із файлу)
на стандартній панелі інструментів;
• клацнути таку саму кнопку на панелі інструментів Рисунки (Малюнки); її
можна вивести на екран за допомогою команди Вид • Панели
инструментов • Рисунки (Вигляд • Панелі інструментів • Малюнки).
У діалоговому вікні, яке відкриється, необхідно знайти потрібний
графічний файл і клацнути кнопку ОК. Малюнок буде вставлено в позицію
курсору.
Розмістивши зображення на веб-сторінці, можна настроїти його
властивості. Для цього використовують діалогове вікно Свойства рисунка
(Властивості малюнка). Щоб відкрити його, слід виділити малюнок за
допомогою миші та виконати одну з таких дій:
• у меню Формат (Формат) вибрати команду Свойства (Властивості);
• відкрити контекстне меню і вибрати команду Свойства рисунка
(Властивості малюнка);
• натиснути клавіші Alt+Enter.
Діалогове вікно Свойства рисунка (Властивості малюнка) має три вкладки:
Вид (Вигляд), Общие (Загальні) та Видеозапись (Відеозапис).
Створення таблиць
Для створення таблиці слід
встановити курсор у місце, де
вона має міститися, і в меню
Таблица (Таблиця) вибрати
команду:
Вставить • Таблица (Вставити
• Таблиця).
Відкриється діалогове вікно
Вставка таблицы (Вставлення
таблиці),
в
якому
можна
визначити
всі
параметри
таблиці.
Створення гіперпосилань
Щоб створити гіперпосилання, необхідно виділити фрагмент тексту або
зображення і виконати одну з таких дій:
• вибрати команду Гиперссылка (Гіперпосилання) у меню Вставка (Вставка);
• відкрити контекстне меню і вибрати у ньому команду Гиперссылка
(Гіперпосилання);
• натиснути клавіші Ctrl+K;
•клацнути кнопку Добавление гиперссылки (Додання гіперпосилання) на
панелі інструментів Стандартная (Стандартна).
Відкриється діалогове вікно, в якому слід виділити об'єкт,
на який вказуватиме посилання, і клацнути кнопку ОК.
Для видалення наявного гіперпосилання слід виділити його, відкрити описане
раніше діалогове вікно і клацнути кнопку Удалить ссылку (Видалити посилання).
1/--страниц
Пожаловаться на содержимое документа